summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-17 07:53:17 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-17 08:23:05 +0100
commitea6791c8b5cfe2f4872117cc5e325f63add2dccc (patch)
treedd93ce0e14bb85ddad0510759b4c771cc605743e /dev-python/cssselect2/cssselect2-0.3.0.ebuild
parentx11-misc/xkeyboard-config: Fix shebang (diff)
downloadgentoo-ea6791c8b5cfe2f4872117cc5e325f63add2dccc.tar.gz
gentoo-ea6791c8b5cfe2f4872117cc5e325f63add2dccc.tar.bz2
gentoo-ea6791c8b5cfe2f4872117cc5e325f63add2dccc.zip
dev-python/cssselect2: Bump to 0.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cssselect2/cssselect2-0.3.0.ebuild')
-rw-r--r--dev-python/cssselect2/cssselect2-0.3.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/cssselect2/cssselect2-0.3.0.ebuild b/dev-python/cssselect2/cssselect2-0.3.0.ebuild
new file mode 100644
index 000000000000..27da62db8521
--- /dev/null
+++ b/dev-python/cssselect2/cssselect2-0.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parses CSS3 Selectors and translates them to XPath 1.0"
+HOMEPAGE="https://cssselect.readthedocs.io/en/latest/
+ https://pypi.org/project/cssselect/
+ https://github.com/Kozea/cssselect2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # junk deps
+ sed -i -e '/^addopts/d' -e '/pytest-runner/d' setup.cfg || die
+ distutils-r1_src_prepare
+}