summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:27:22 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:48:09 -0500
commitbe295af99caede445827845a8cfe84cf1175f7a5 (patch)
tree3f8634fa9e96236800fac373ac770ad9c3d93860 /dev-python/cursive/cursive-0.2.2-r1.ebuild
parentdev-python/castellan: 3.6.0 bump (diff)
downloadgentoo-be295af99caede445827845a8cfe84cf1175f7a5.tar.gz
gentoo-be295af99caede445827845a8cfe84cf1175f7a5.tar.bz2
gentoo-be295af99caede445827845a8cfe84cf1175f7a5.zip
dev-python/cursive: 0.2.2-r1 bump for py38
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/cursive/cursive-0.2.2-r1.ebuild')
-rw-r--r--dev-python/cursive/cursive-0.2.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/cursive/cursive-0.2.2-r1.ebuild b/dev-python/cursive/cursive-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..737826a40925
--- /dev/null
+++ b/dev-python/cursive/cursive-0.2.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cursive implements OpenStack-specific validation of digital signatures."
+HOMEPAGE="https://github.com/openstack/cursive"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/castellan-0.4.0[${PYTHON_USEDEP}]
+"