summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-12 15:06:25 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-12 15:10:28 +0100
commit010baf8ef98bad760b1a9b86e21185750b57a75f (patch)
treecdf8b736fc5b5b6ba08e3630476b80e320a7aaf8 /dev-python/curtsies/curtsies-0.2.6.ebuild
parentdev-lang/swi-prolog: bump 7.3 development version (diff)
downloadgentoo-010baf8ef98bad760b1a9b86e21185750b57a75f.tar.gz
gentoo-010baf8ef98bad760b1a9b86e21185750b57a75f.tar.bz2
gentoo-010baf8ef98bad760b1a9b86e21185750b57a75f.zip
dev-python/curtsies: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/curtsies/curtsies-0.2.6.ebuild')
-rw-r--r--dev-python/curtsies/curtsies-0.2.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/curtsies/curtsies-0.2.6.ebuild b/dev-python/curtsies/curtsies-0.2.6.ebuild
new file mode 100644
index 000000000000..df6feab59f2a
--- /dev/null
+++ b/dev-python/curtsies/curtsies-0.2.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Curses-like terminal wrapper, with colored strings"
+HOMEPAGE="https://github.com/thomasballinger/curtsies"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/blessings-1.5[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]
+ >=dev-python/wcwidth-0.1.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --verbose tests || die
+}