summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-09-27 19:29:56 +0700
committerAndrey Grozin <grozin@gentoo.org>2016-09-27 19:29:56 +0700
commit7819ce5f51eecb8144778a010b28a7e864c1c549 (patch)
tree863a8149d2d5f65eaeb90c5785ef49149774f742 /dev-python/curtsies/curtsies-0.2.9.ebuild
parentpackage.mask: Unmasked bash-4.4/readline-7.0 for wider testing. (diff)
downloadgentoo-7819ce5f51eecb8144778a010b28a7e864c1c549.tar.gz
gentoo-7819ce5f51eecb8144778a010b28a7e864c1c549.tar.bz2
gentoo-7819ce5f51eecb8144778a010b28a7e864c1c549.zip
dev-python/curtsies: bump to 0.2.9, python3_5 added
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/curtsies/curtsies-0.2.9.ebuild')
-rw-r--r--dev-python/curtsies/curtsies-0.2.9.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/curtsies/curtsies-0.2.9.ebuild b/dev-python/curtsies/curtsies-0.2.9.ebuild
new file mode 100644
index 000000000000..67d2dd2523cc
--- /dev/null
+++ b/dev-python/curtsies/curtsies-0.2.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Curses-like terminal wrapper, with colored strings"
+HOMEPAGE="https://github.com/thomasballinger/curtsies"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/blessings-1.5[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]
+ >=dev-python/wcwidth-0.1.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --verbose tests || die
+}