summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-24 20:29:24 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-24 20:48:35 +0100
commit19ee56a416c957e5e83b8260dbf54249cdfe9ff9 (patch)
treed21662abd29a48911039b86410a76363c98ab0de /dev-python/curtsies/curtsies-0.3.5.ebuild
parentdev-python/cwcwidth: New package (Cython version of wcwidth) (diff)
downloadgentoo-19ee56a416c957e5e83b8260dbf54249cdfe9ff9.tar.gz
gentoo-19ee56a416c957e5e83b8260dbf54249cdfe9ff9.tar.bz2
gentoo-19ee56a416c957e5e83b8260dbf54249cdfe9ff9.zip
dev-python/curtsies: Bump to 0.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/curtsies/curtsies-0.3.5.ebuild')
-rw-r--r--dev-python/curtsies/curtsies-0.3.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/curtsies/curtsies-0.3.5.ebuild b/dev-python/curtsies/curtsies-0.3.5.ebuild
new file mode 100644
index 000000000000..234472088a99
--- /dev/null
+++ b/dev-python/curtsies/curtsies-0.3.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Curses-like terminal wrapper, with colored strings"
+HOMEPAGE="https://github.com/thomasballinger/curtsies"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/blessings-1.5[${PYTHON_USEDEP}]
+ dev-python/cwcwidth[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pyte[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest