summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 09:56:41 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-02 10:26:48 +0100
commit428204cf4a609b0814145e33e7e782369930dcb8 (patch)
tree95c5d5730d38914d51091dd2862e7370a655f292 /dev-python/cython-test-exception-raiser
parentdev-python/cython-test-exception-raiser: Add pypy3 love (diff)
downloadgentoo-428204cf4a609b0814145e33e7e782369930dcb8.tar.gz
gentoo-428204cf4a609b0814145e33e7e782369930dcb8.tar.bz2
gentoo-428204cf4a609b0814145e33e7e782369930dcb8.zip
dev-python/cython-test-exception-raiser: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cython-test-exception-raiser')
-rw-r--r--dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2-r1.ebuild b/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..94f599d7638a
--- /dev/null
+++ b/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A trivial extension that just raises an exception (for testing)"
+HOMEPAGE="
+ https://pypi.org/project/cython-test-exception-raiser/
+ https://github.com/twisted/cython-test-exception-raiser/"
+SRC_URI="
+ https://github.com/twisted/cython-test-exception-raiser/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"