summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-18 01:14:35 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-18 01:16:36 +0200
commit0a2e5bdc00160c10e79ec06b53b0ba92cb0678cb (patch)
tree251f88459dfd99624b43b585210c64a737ffe3de /dev-python/daemonize/daemonize-2.5.0.ebuild
parentdev-libs/libappindicator: keyword 12.10.1_p20200706 for ~riscv (diff)
downloadgentoo-0a2e5bdc00160c10e79ec06b53b0ba92cb0678cb.tar.gz
gentoo-0a2e5bdc00160c10e79ec06b53b0ba92cb0678cb.tar.bz2
gentoo-0a2e5bdc00160c10e79ec06b53b0ba92cb0678cb.zip
dev-python/daemonize: enable py3.10 and tests
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/daemonize/daemonize-2.5.0.ebuild')
-rw-r--r--dev-python/daemonize/daemonize-2.5.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/daemonize/daemonize-2.5.0.ebuild b/dev-python/daemonize/daemonize-2.5.0.ebuild
index ace9fe951e98..c173bf76ab7d 100644
--- a/dev-python/daemonize/daemonize-2.5.0.ebuild
+++ b/dev-python/daemonize/daemonize-2.5.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -14,3 +14,7 @@ SRC_URI="https://github.com/thesharp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" tests/test.py -v || die "Tests failed with ${EPYTHON}"
+}