summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/dap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/dap')
-rw-r--r--dev-python/dap/Manifest1
-rw-r--r--dev-python/dap/dap-2.2.6.7-r1.ebuild35
-rw-r--r--dev-python/dap/metadata.xml16
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/dap/Manifest b/dev-python/dap/Manifest
new file mode 100644
index 000000000000..60a133ddfcc4
--- /dev/null
+++ b/dev-python/dap/Manifest
@@ -0,0 +1 @@
+DIST dap-2.2.6.7.tar.gz 54055 SHA256 89601cb351681e7cdc621c2aa9d8788d180d2f16f6d341f55f513c489af8701a SHA512 8b9ee3fbbe15777f050f067be29a8d4e8e8b58aa8b430f69330da262593808838c8e0b3946a6f7932dc5d4d1b9dad12be73b98f82a6c399f7383f2630ad6ce47 WHIRLPOOL f5f055bfa3f303643ac0593a972b732f4b431284e8c959c49ca3e41182d3a8b0bfb844ba9471318308a54408fb08ee19525679c0d9460ce29753ecc616883894
diff --git a/dev-python/dap/dap-2.2.6.7-r1.ebuild b/dev-python/dap/dap-2.2.6.7-r1.ebuild
new file mode 100644
index 000000000000..9a98974ed060
--- /dev/null
+++ b/dev-python/dap/dap-2.2.6.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Data Access Protocol client and server"
+HOMEPAGE="http://pydap.org http://pypi.python.org/pypi/dap http://pypi.python.org/pypi/Pydap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="server"
+
+RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]
+ server? (
+ dev-python/cheetah[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/pastescript[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/bugs docs/Changelog docs/history README TODO )
+
+src_prepare() {
+ sed -e "s/'dap.plugins'/'dap', 'dap.plugins'/" -i setup.py || die "sed failed"
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/dap/metadata.xml b/dev-python/dap/metadata.xml
new file mode 100644
index 000000000000..eb4573dd0945
--- /dev/null
+++ b/dev-python/dap/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-geosciences</herd>
+ <herd>python</herd>
+ <use>
+ <flag name="server">Enable OpenDAP server support</flag>
+ </use>
+ <longdescription lang="en">pydap is a Python implementation of the Data Access Protocol
+ a.k.a. DODS or OPeNDAP. Using pydap as a client you can access
+ hundreds of scientific datasets. You can also use it to serve your
+ data from a variety of formats.</longdescription>
+ <upstream>
+ <remote-id type="pypi">dap</remote-id>
+ </upstream>
+</pkgmetadata>