summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-03-18 18:25:55 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-03-18 20:10:48 +0000
commitac737bb6037b8558dfc04989f292c23af0df5613 (patch)
tree7b0ad08350dc0ae709c838aa4add5dd924a6efd6 /dev-python/dask/dask-0.8.1.ebuild
parentdev-python/partd: initial import (diff)
downloadgentoo-ac737bb6037b8558dfc04989f292c23af0df5613.tar.gz
gentoo-ac737bb6037b8558dfc04989f292c23af0df5613.tar.bz2
gentoo-ac737bb6037b8558dfc04989f292c23af0df5613.zip
dev-python/dask: initial import
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/dask/dask-0.8.1.ebuild')
-rw-r--r--dev-python/dask/dask-0.8.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/dask/dask-0.8.1.ebuild b/dev-python/dask/dask-0.8.1.ebuild
new file mode 100644
index 000000000000..b168f7b2e7e2
--- /dev/null
+++ b/dev-python/dask/dask-0.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="http://dask.pydata.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/bokeh[${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/partd[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die
+}