summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-15 08:57:32 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-15 10:52:06 +0100
commit8fa5feb794c3bd8e822edc5fbef96c0566914313 (patch)
tree0b535f44916810551efe1a576ff41df2b660468b /dev-python/dask
parentdev-libs/nss-pem: stabilize 1.0.8 for x86 (diff)
downloadgentoo-8fa5feb794c3bd8e822edc5fbef96c0566914313.tar.gz
gentoo-8fa5feb794c3bd8e822edc5fbef96c0566914313.tar.bz2
gentoo-8fa5feb794c3bd8e822edc5fbef96c0566914313.zip
dev-python/dask: Bump to 2022.01.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2022.01.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index efdf6429f660..0d136025a401 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,2 +1,3 @@
DIST dask-2021.11.0.tar.gz 3971871 BLAKE2B be2c28782e3e870b62e70041bd7572783ff9eef61c27d2fa092f00b74ae23877163e3c00f59f67c5c39b6fefd723cb2c25cdc58b5f5c76c08ef1d686f256cb25 SHA512 cebdef68b2c40348c84627505f4e1f17f998aed603d590be5acc7b78233362330352be395396be00f72215b738e9393ef08eeae8ed0fb933466c1c2d6158e5ea
DIST dask-2021.12.0.gh.tar.gz 3987797 BLAKE2B f6c1954ff41048861fcedbc56bd658989dece828613344e876e097d03f93338c194d66e62dd9fa1605b5dfd0362374a1dd2e00a383eec4476db16ac04de29266 SHA512 e9ce4613bf1ccfda7ce85bd90ff8f24d59335f02a941c12335214a2636f46ae1e1e8c2b1777ca9b9dd83f190071a2893b02bee129a68e9b7468c30f2a45df68e
+DIST dask-2022.01.0.gh.tar.gz 4903414 BLAKE2B 495531085d126d51c03b1f6dda490cd2d859276821a6d1ab6c2b90fcf6a4cec925b9fcafdf3b3da46344391e77a9bd09cf023f25b0f84bbe6ca8fa36b0bed73f SHA512 3fc25f6ccfca8354e3c6e2425f4d2c8b85807944b02cd1e872931f5b34d82c9afc6f5ffb17b5f835c531ebac4b6759ddaa81897a6f3d2aeee2c09935f221f62d
diff --git a/dev-python/dask/dask-2022.01.0.ebuild b/dev-python/dask/dask-2022.01.0.ebuild
new file mode 100644
index 000000000000..a8c79554a055
--- /dev/null
+++ b/dev-python/dask/dask-2022.01.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/dask-2021.10.0-warning.patch
+)
+
+EPYTEST_DESELECT=(
+ # another test relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+)
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}