summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-11 20:56:15 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-11 22:18:35 +0100
commita10b26eb40ece056513e950f1b6ca10c27df615b (patch)
tree3f7630d80f12cf9d58b3eedc4fe8726ba0a0c2b3 /dev-python/dask
parentdev-python/pytest: Bump to 7.0.1 (diff)
downloadgentoo-a10b26eb40ece056513e950f1b6ca10c27df615b.tar.gz
gentoo-a10b26eb40ece056513e950f1b6ca10c27df615b.tar.bz2
gentoo-a10b26eb40ece056513e950f1b6ca10c27df615b.zip
dev-python/dask: Bump to 2022.02.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2022.02.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 0025f79a2561..c1019d17cc69 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -2,3 +2,4 @@ DIST dask-2021.11.0.tar.gz 3971871 BLAKE2B be2c28782e3e870b62e70041bd7572783ff9e
DIST dask-2021.12.0.gh.tar.gz 3987797 BLAKE2B f6c1954ff41048861fcedbc56bd658989dece828613344e876e097d03f93338c194d66e62dd9fa1605b5dfd0362374a1dd2e00a383eec4476db16ac04de29266 SHA512 e9ce4613bf1ccfda7ce85bd90ff8f24d59335f02a941c12335214a2636f46ae1e1e8c2b1777ca9b9dd83f190071a2893b02bee129a68e9b7468c30f2a45df68e
DIST dask-2022.01.0.gh.tar.gz 4903414 BLAKE2B 495531085d126d51c03b1f6dda490cd2d859276821a6d1ab6c2b90fcf6a4cec925b9fcafdf3b3da46344391e77a9bd09cf023f25b0f84bbe6ca8fa36b0bed73f SHA512 3fc25f6ccfca8354e3c6e2425f4d2c8b85807944b02cd1e872931f5b34d82c9afc6f5ffb17b5f835c531ebac4b6759ddaa81897a6f3d2aeee2c09935f221f62d
DIST dask-2022.01.1.gh.tar.gz 4916694 BLAKE2B b793b8931818e619ef701f5145a27b8c90e237a51b79f370e994a5e7cdace115808c8f657836785059b1cb495b64f85cb5331759de76c79e55f2cd45f1c3494e SHA512 82789735279c71cff5a0123aa95d3311bd5d08f0332edc22468287e573e4b293a13da514a1844879073490b23ead2ff86f4492175c0a4211f727e8537bac5662
+DIST dask-2022.02.0.gh.tar.gz 5028629 BLAKE2B efe6e6143d030024abae6d33c98289a37e3a6003da15ea6c4132a5610bf74763f9d921a1f04bf4a28a6ca60405e89fad3ca0491f67da6661c45853d172551c06 SHA512 397dabd3caabac0657808ff031299a1461c7acf4a123db4d1876d8e72a0ae971266dcb256e29498b1988b1b4bea506db3aec962b876f280ec532b96da35d356c
diff --git a/dev-python/dask/dask-2022.02.0.ebuild b/dev-python/dask/dask-2022.02.0.ebuild
new file mode 100644
index 000000000000..77fb824ab55c
--- /dev/null
+++ b/dev-python/dask/dask-2022.02.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/dask-2021.10.0-warning.patch
+)
+
+EPYTEST_DESELECT=(
+ # another test relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+)
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}