summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-27 11:27:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-27 11:29:44 +0200
commita474658a37417cb41a3450c2d9d459d2ff4e7b49 (patch)
tree47c8f47aeb5885bbd81ac873df5da4eaf72e5e26 /dev-python/dask
parentdev-python/google-api-core: Remove old (diff)
downloadgentoo-a474658a37417cb41a3450c2d9d459d2ff4e7b49.tar.gz
gentoo-a474658a37417cb41a3450c2d9d459d2ff4e7b49.tar.bz2
gentoo-a474658a37417cb41a3450c2d9d459d2ff4e7b49.zip
dev-python/dask: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2022.05.0.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index d06b03d91bc5..c653981768d2 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,4 +1,3 @@
-DIST dask-2022.05.0.gh.tar.gz 8658529 BLAKE2B 0b09ef38137d9c395384549fd8a3b0218ad1761ccb1816f8fc4f4af7328215716603e3f41b8cc3bf7044ff42b72eee277147b3bd03da48467cccc88f239bb2bd SHA512 15605321143f354ffb9c890823f5751131d942cc16c523b2d00bdcc752ddc5243525f7cda138091604c8f2f9c5b4a309b1efc95f483b753673df98cc8a81ce81
DIST dask-2022.05.2.gh.tar.gz 8721528 BLAKE2B 42b83ca6fe58b014d3aa90cc99dc4b9b631d6b5bb3243a2a2bd1bcfc6f9ffe5d545b7bcc43edfd3299273e105f7355fbaa9490043a12a8c303773d0e08e63d8c SHA512 1d6ce8db1c83ac22f081beec8667f35acda48578263c637ee294934c729d16a7aca4259e0dde6fed6f2dc9924490589610fc3fc4225dfe07552b15b6af20d8d5
DIST dask-2022.6.0.gh.tar.gz 8727952 BLAKE2B 060595de52ec64db83bf56d5b4c975ac22009fbe4efadd903ddafa80400e8b5706d60a47445b70f513a73cc915dc696b7ee17831f6c4aed4f55ca11bd8c4fcce SHA512 92619558dc8ed4808842cf45bad703443bfc38f2206fe15e65e5dc457040042eeefc9cd0fb16a8322c4a8972dd10b0b7250451d1883a148e2238f5bcb3f0555e
DIST dask-2022.6.1.gh.tar.gz 8729249 BLAKE2B 211beeb3960569aa1cb68a4fd9b261a417297de5dc406d50bc54342239227ea01e2158b618bd889862a7eff8bb01bb43d098937bb3911f088250957caa672d04 SHA512 6e06b63dd5c7f1d7c6c7dce867ffa42b956023b313b25245a339f698b06bea17a03cc4ead9bd5aef8ddf081750cad4df4b6b2972038315c89585221382c9e95c
diff --git a/dev-python/dask/dask-2022.05.0.ebuild b/dev-python/dask/dask-2022.05.0.ebuild
deleted file mode 100644
index 11e5ccbb938b..000000000000
--- a/dev-python/dask/dask-2022.05.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
-HOMEPAGE="
- https://dask.org/
- https://github.com/dask/dask/
- https://pypi.org/project/dask/
-"
-SRC_URI="
- https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
- >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
- >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
- >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/toolz[${PYTHON_USEDEP}]
- test? (
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/numexpr[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # another test relying on -Werror
- "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
- # TODO
- dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
- dask/tests/test_config.py::test__get_paths
-)
-
-python_test() {
- epytest -p no:flaky -m "not network"
-}