summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-22 08:35:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-22 09:40:42 +0200
commitb0b58afd7c211938e7aa2aafe821519a8980ef00 (patch)
tree8add67414062f147ff693a9f01d9455f1e772092 /dev-python/dask
parentdev-python/cfn-lint: Bump to 0.65.1 (diff)
downloadgentoo-b0b58afd7c211938e7aa2aafe821519a8980ef00.tar.gz
gentoo-b0b58afd7c211938e7aa2aafe821519a8980ef00.tar.bz2
gentoo-b0b58afd7c211938e7aa2aafe821519a8980ef00.zip
dev-python/dask: Bump to 2022.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2022.9.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 18a5cd807d74..7ac7d3164dbe 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,2 +1,3 @@
DIST dask-2022.8.1.gh.tar.gz 8759920 BLAKE2B bc84706772072a1df2a1c0089f9bc1332a0110430f1c6f2e120e76f565b0666fb0f7f9ac6c25da356f2825e0cd8dfa5b2ef7998d3a231aefc41a5ce09980a22a SHA512 ba042cf069b88c752a371a6ea2df69dd75dabd934befa2d91f4e1e754ad197a14369935452125a621d14527e0d6a0a3a2abdee8f127aa05c6c812116cb27dc3e
DIST dask-2022.9.0.gh.tar.gz 8762083 BLAKE2B 60c7a37124b61b49fc06a754b5842695fd63d234e087ec44a40793aeb330034e0d5e3caaedd239fd498a9b01c2bc450f62cdc22848bfd654bfdab6a07d9be7de SHA512 a88f71b9e8cdc69ce3a4babbc2434f830110df284d56eec37cadb6b81add3cd5f2e751ea5e9b390d112d16ee0952c296368851889fec202e3601c2fcf8f52a97
+DIST dask-2022.9.1.gh.tar.gz 8766675 BLAKE2B da4735dd860b96d691bbe3782ce04fb4e53a265984dc52593ecd1cbd1a1e536ad2677998e01bcfa99d783255ce053a44c4ed4cb0ce83128520755c20530bca3f SHA512 944d333bbe2f946b85173d289e287737816359a959b61d9bf2b9ef0f75173482a2912355fd71f8a8aa29e58f5b66a91909dc53c1cd269ab2bc569bad62a67f6c
diff --git a/dev-python/dask/dask-2022.9.1.ebuild b/dev-python/dask/dask-2022.9.1.ebuild
new file mode 100644
index 000000000000..6ad6f0bd45e1
--- /dev/null
+++ b/dev-python/dask/dask-2022.9.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://www.dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # another test relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+ dask/array/tests/test_linalg.py::test_solve_assume_a
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
+)
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}