summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-19 09:21:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-19 10:36:02 +0100
commitbbf776e5634ffca00b50ebfef5ef9b2a1b01ec62 (patch)
tree598da4df11e00c4e88bf3f336b4b5d37c5dd3e53 /dev-python/dask
parentdev-python/pytest-flake8: Bump to 1.1.1 (diff)
downloadgentoo-bbf776e5634ffca00b50ebfef5ef9b2a1b01ec62.tar.gz
gentoo-bbf776e5634ffca00b50ebfef5ef9b2a1b01ec62.tar.bz2
gentoo-bbf776e5634ffca00b50ebfef5ef9b2a1b01ec62.zip
dev-python/dask: Bump to 2022.03.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2022.03.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 0644ba6191aa..8bebc5492ac2 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -4,3 +4,4 @@ DIST dask-2022.01.0.gh.tar.gz 4903414 BLAKE2B 495531085d126d51c03b1f6dda490cd2d8
DIST dask-2022.01.1.gh.tar.gz 4916694 BLAKE2B b793b8931818e619ef701f5145a27b8c90e237a51b79f370e994a5e7cdace115808c8f657836785059b1cb495b64f85cb5331759de76c79e55f2cd45f1c3494e SHA512 82789735279c71cff5a0123aa95d3311bd5d08f0332edc22468287e573e4b293a13da514a1844879073490b23ead2ff86f4492175c0a4211f727e8537bac5662
DIST dask-2022.02.0.gh.tar.gz 5028629 BLAKE2B efe6e6143d030024abae6d33c98289a37e3a6003da15ea6c4132a5610bf74763f9d921a1f04bf4a28a6ca60405e89fad3ca0491f67da6661c45853d172551c06 SHA512 397dabd3caabac0657808ff031299a1461c7acf4a123db4d1876d8e72a0ae971266dcb256e29498b1988b1b4bea506db3aec962b876f280ec532b96da35d356c
DIST dask-2022.02.1.gh.tar.gz 5034850 BLAKE2B ec5ff745c3dbe19bbbdc533be6bc86537b532943cc798932f57051001648fb97cc39890060d064f7db5f3fbe6aa72d784393a3ccdcce67beedf3540a2a925d0b SHA512 6f66b5a904ea7ab0137465f622d1606a218b4ddc8b91939759098c66c7b749c674c750bf0caa6b53c7cf9d192312c0991d8e6144cebf9745eb9dfd4583b8b66c
+DIST dask-2022.03.0.gh.tar.gz 8192610 BLAKE2B 1099dac34487dc51b9010746920e64e4e7e4a07bb1f3b82ebe069afdd2f64feccc7c97291a1a4d1fc089cbc6f0b6f40a81fedc96be11f85920558ad305b63641 SHA512 e32b82d76d6b3d1494c32bcec171e3fc09e38b6cc94729b3f82bf0618445e58e4bd5361efb359e5894af2703bdb4f3f100916d4d7fc905faecc9a5262559754a
diff --git a/dev-python/dask/dask-2022.03.0.ebuild b/dev-python/dask/dask-2022.03.0.ebuild
new file mode 100644
index 000000000000..d78a53023b58
--- /dev/null
+++ b/dev-python/dask/dask-2022.03.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # another test relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+)
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}