summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-03 08:56:34 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-03 10:51:22 +0100
commitef46dee1a5e0c85ec1c86b6262ec4443c3a3c1ef (patch)
tree10c4cea72b674c27fbb5be557c68efd42c43fb7e /dev-python/dask
parentprofiles/package.mask: mask old net-ssh slot for removal (diff)
downloadgentoo-ef46dee1a5e0c85ec1c86b6262ec4443c3a3c1ef.tar.gz
gentoo-ef46dee1a5e0c85ec1c86b6262ec4443c3a3c1ef.tar.bz2
gentoo-ef46dee1a5e0c85ec1c86b6262ec4443c3a3c1ef.zip
dev-python/dask: Bump to 2022.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2022.12.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index cbf8640cf086..a7c66adf2eec 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,2 +1,3 @@
DIST dask-2022.10.1.gh.tar.gz 8781108 BLAKE2B 2030cf0670d054a222123ef836573ae7f5e574a879089a57b9a7730ae5cc33e43da2af3b470ce24174169f9045415cf71543aa05fd368b4471111a01982c5b7c SHA512 58b5515be46086a02a895f97db7120423a51651dcefef6f14d631a719e4faa0315b7a32640e4cd823064ae754319b84cc7c74bb4d4e9d904177816115abc48e5
DIST dask-2022.11.1.gh.tar.gz 8223813 BLAKE2B 1c7f4ed26022673ebb3a337520eee4cfb6c48449c06bfc1906431de6f03b4a4df313630326f96cf5ef8aefdc1306ded21158946997d9cf79153f7d83659575bd SHA512 c954de12d512e5be7d4891e9e702ae21c69e42be703e3859bb2d6893dd600fc7255ce25677bfdf9e119f84450510877ce018ac8ef425291fdf90c04af169e2e7
+DIST dask-2022.12.0.gh.tar.gz 8226972 BLAKE2B 56def762c1899df9b355f54484b77cfde125e85287db488388130c92b388f014b7ddf8ccd4614918a5c6a15513c7fab207b4c2231105880a893af32e768ed675 SHA512 bc29f3735fb977a5b523d7ffbf55a99fd7a386388f1ebec3c44196d3b6870393163e023a2c64f1f8e7b8aae5342b9b0041a6628df72d14a0127513acf7f6c529
diff --git a/dev-python/dask/dask-2022.12.0.ebuild b/dev-python/dask/dask-2022.12.0.ebuild
new file mode 100644
index 000000000000..8f2f893b8e30
--- /dev/null
+++ b/dev-python/dask/dask-2022.12.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://www.dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # another test relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+ dask/array/tests/test_linalg.py::test_solve_assume_a
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
+)
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}