summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 10:12:49 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 10:16:47 +0200
commit130635d958ee8c84dfdb22959bde0644cd96190c (patch)
tree4c84f79d4e250215b14a585d87467e2c4078bafc /dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild
parentdev-python/pygobject: Remove old (diff)
downloadgentoo-130635d958ee8c84dfdb22959bde0644cd96190c.tar.gz
gentoo-130635d958ee8c84dfdb22959bde0644cd96190c.tar.bz2
gentoo-130635d958ee8c84dfdb22959bde0644cd96190c.zip
dev-python/dbus-python: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild')
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild b/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild
new file mode 100644
index 000000000000..3e8404ab9e9d
--- /dev/null
+++ b/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit autotools python-r1
+
+DESCRIPTION="Python bindings for the D-Bus messagebus"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings https://dbus.freedesktop.org/doc/dbus-python/"
+SRC_URI="https://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
+
+IUSE="doc examples test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="${PYTHON_DEPS}
+ >=sys-apps/dbus-1.8:=
+ >=dev-libs/glib-2.40
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )
+ test? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/tappy[${PYTHON_USEDEP}] )
+"
+
+PATCHES=( "${FILESDIR}/${P}-py39.patch" )
+
+python_check_deps() {
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ default
+ # Update py-compile, bug 529502.
+ eautoreconf
+ python_copy_sources
+}
+
+src_configure() {
+ use doc && python_setup
+ local SPHINX_IMPL=${EPYTHON}
+
+ configuring() {
+ local myconf=(
+ --disable-documentation
+ )
+ [[ ${EPYTHON} == ${SPHINX_IMPL} ]] &&
+ myconf+=( --enable-documentation )
+
+ econf "${myconf[@]}"
+ }
+ python_foreach_impl run_in_build_dir configuring
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
+ find "${D}" -name '*.la' -type f -delete || die
+
+ use examples && dodoc -r examples
+}