summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-24 13:51:49 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-24 14:19:53 +0200
commit5654b50c536b43ea8fecc2c83376c1c35c170c5e (patch)
tree2865a08ad57b1f8ff5d2a3d02b4293a5011cc411 /dev-python/dbus-python/dbus-python-1.2.8.ebuild
parentdev-python/dbus-python: Remove redundant configure options (diff)
downloadgentoo-5654b50c536b43ea8fecc2c83376c1c35c170c5e.tar.gz
gentoo-5654b50c536b43ea8fecc2c83376c1c35c170c5e.tar.bz2
gentoo-5654b50c536b43ea8fecc2c83376c1c35c170c5e.zip
dev-python/dbus-python: Bump to 1.2.8 (now using sphinx for docs!)
Diffstat (limited to 'dev-python/dbus-python/dbus-python-1.2.8.ebuild')
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.8.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/dbus-python/dbus-python-1.2.8.ebuild b/dev-python/dbus-python/dbus-python-1.2.8.ebuild
new file mode 100644
index 000000000000..3857687ebfe5
--- /dev/null
+++ b/dev-python/dbus-python/dbus-python-1.2.8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit autotools python-r1
+
+DESCRIPTION="Python bindings for the D-Bus messagebus"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings https://dbus.freedesktop.org/doc/dbus-python/"
+SRC_URI="https://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=sys-apps/dbus-1.8:=
+ >=dev-libs/glib-2.40
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )
+ test? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/tappy[${PYTHON_USEDEP}] )"
+
+python_check_deps() {
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ default
+ # Update py-compile, bug 529502.
+ eautoreconf
+ python_copy_sources
+}
+
+src_configure() {
+ use doc && python_setup
+ local SPHINX_IMPL=${EPYTHON}
+
+ configuring() {
+ local myconf=(
+ --disable-documentation
+ )
+ [[ ${EPYTHON} == ${SPHINX_IMPL} ]] &&
+ myconf+=( --enable-documentation )
+
+ econf "${myconf[@]}"
+ }
+ python_foreach_impl run_in_build_dir configuring
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
+ find "${D}" -name "*.la" -delete || die
+
+ use examples && dodoc -r examples
+}