summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-26 20:01:51 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-26 23:24:11 -0500
commita2a44766bebeba2532c392aa83d8c6f83c4bb81a (patch)
treee7916779914f3dcd9e76df7911474a3df3b3a8e7 /dev-python/debtcollector
parentdev-python/wrapt: 1.10.10 bup (diff)
downloadgentoo-a2a44766bebeba2532c392aa83d8c6f83c4bb81a.tar.gz
gentoo-a2a44766bebeba2532c392aa83d8c6f83c4bb81a.tar.bz2
gentoo-a2a44766bebeba2532c392aa83d8c6f83c4bb81a.zip
dev-python/debtcollector: 1.17.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/debtcollector')
-rw-r--r--dev-python/debtcollector/Manifest1
-rw-r--r--dev-python/debtcollector/debtcollector-1.17.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/debtcollector/Manifest b/dev-python/debtcollector/Manifest
index 9b0ba800394c..812476a7a765 100644
--- a/dev-python/debtcollector/Manifest
+++ b/dev-python/debtcollector/Manifest
@@ -1,2 +1,3 @@
DIST debtcollector-1.11.0.tar.gz 26266 SHA256 733afa881c844a40ef4623ab73ce1862e505bc4655635da3a91d8f3482677785 SHA512 9dcbfdaec5d16714d17eca2bfce7049c0a042b2370b1be5a4a0c0057dc28bf060ba570639581ceb5e5c27f2117f9001e4b2bb350899bdab0c0c7cdc3098a9bb2 WHIRLPOOL 3456da61c660b4102c391c38910158fcc3907c41cd7a5ed079bfa8366af42bbff9291c42e5e00a14b495c2443a0d4febd5be1da536901eb184bec9cb0c9142e7
+DIST debtcollector-1.17.0.tar.gz 28122 SHA256 71e3350b6b97acede200f30b3858749b21303a70fde4ded26e4cbe599a3b0466 SHA512 8c35cdc00f9161cf940ff22a4b155e281adf66bb2dd16870a40017b05553387e37d9bd988bb4adcb89c5f75ca63d626a9de949986caa877d4d70d8cbf90daf63 WHIRLPOOL a2c36051735d0c2a9ffbd839518c7b467a7f60f73598e9c26dfa0dc7c86c031b00fdd68759993450c8e61374e5549cc305d34bf5110e015e8c227d50d22449e4
DIST debtcollector-1.3.0.tar.gz 21853 SHA256 9a65cf09239eab75b961ef609b3176ed2487bedcfa0a465331661824e1c8db8f SHA512 b53ef131599fb04abb9f11e8abe3dc8447a595695bab505be642c03925e0da625e6a10944ec10863526645080ed3ce43b9a5138a1f7ba91511ade6daf42d018a WHIRLPOOL 04c6ee34a48955a86535c3161005417f5c5dfca9152e092c3856d61a4707f6249245398006d0da0c31ffa7103ab69a566bf84d7321b70362d59f359b5225622f
diff --git a/dev-python/debtcollector/debtcollector-1.17.0.ebuild b/dev-python/debtcollector/debtcollector-1.17.0.ebuild
new file mode 100644
index 000000000000..62a811c24067
--- /dev/null
+++ b/dev-python/debtcollector/debtcollector-1.17.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python deprecation patterns and strategies that collect technical debt"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ !~dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ dev-python/doc8[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || di
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}