summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-14 21:00:28 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-14 21:05:44 +0100
commit92f99d56e08da1f899566a0e747e2ad4ec533aa4 (patch)
treed90388e2af197c06df086fb9c278c5b9044bc6fb /dev-python/deepdiff
parentdev-python/pypdf: Bump to 3.17.1 (diff)
downloadgentoo-92f99d56e08da1f899566a0e747e2ad4ec533aa4.tar.gz
gentoo-92f99d56e08da1f899566a0e747e2ad4ec533aa4.tar.bz2
gentoo-92f99d56e08da1f899566a0e747e2ad4ec533aa4.zip
dev-python/deepdiff: Bump to 6.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/deepdiff')
-rw-r--r--dev-python/deepdiff/Manifest1
-rw-r--r--dev-python/deepdiff/deepdiff-6.7.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/deepdiff/Manifest b/dev-python/deepdiff/Manifest
index 373a033c6268..384d32d0bb8f 100644
--- a/dev-python/deepdiff/Manifest
+++ b/dev-python/deepdiff/Manifest
@@ -1,2 +1,3 @@
DIST deepdiff-6.6.1.tar.gz 402840 BLAKE2B 78fa059644d068fb0e6f16a81ba91d0e776f91eda6f049f73d57bd176a9bbca5fc60f301e8ac652ba1339be2474c9eb6912ce532d720328d2b017bfcc52196dc SHA512 5a18bdb5d5dbc7b6de39d90fc3a740ddeeddd0742953f8618eefafbd0c086138219dbb3a515ead40b315c28590b642721b9350d2b9cc9e4a1e9ea8a8dbb25712
DIST deepdiff-6.7.0.tar.gz 406189 BLAKE2B 8425e96f7a427a6476ef3ec1ba3082c9f139658046e920cb90316e26951524d88e956bfc4cf85bb3a273349312cf96a91885cbef602ec07c494c1319babd1ede SHA512 36f554839b5de5d9a75d39a53b214e50d10e6a0f9932dc7ec222f4f911c0d424359d4df3bae083b3766dc68ed9f62e3b6bd4e8eb981fb7fa537fc4298f5c682d
+DIST deepdiff-6.7.1.tar.gz 409107 BLAKE2B b52b95f166eb564a5357a5f8f2d8759f9931333b857f5cfc62ac99ffb67d8be9cc3972c76e16d9a28b752983db2903089e2bcc0702e768e07d49b5c7fada4bc7 SHA512 89cf198aeaa392e9609641a9bbc1331c8badf3d4b7cafb1afef00f6f6237524dec72467abf9a9afeba5dc08b8f7e8321827faec5b9a8c27ffff97bfc3fdb0db0
diff --git a/dev-python/deepdiff/deepdiff-6.7.1.ebuild b/dev-python/deepdiff/deepdiff-6.7.1.ebuild
new file mode 100644
index 000000000000..de71d5e0cadf
--- /dev/null
+++ b/dev-python/deepdiff/deepdiff-6.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A library for comparing dictionaries, iterables, strings and other objects"
+HOMEPAGE="
+ https://github.com/seperman/deepdiff/
+ https://pypi.org/project/deepdiff/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.1.3[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ >=dev-python/jsonpickle-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.23.5[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests pytest