summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-05-06 20:43:01 +0200
committerPacho Ramos <pacho@gentoo.org>2020-05-06 20:46:16 +0200
commit714d3a1802c59e91297223ee20daeb519c12d476 (patch)
tree6d44afd6b25da4e582c932b74fba2394be121cd5 /dev-python/defcon
parentdev-python/pyclipper: Needs unittest2 (diff)
downloadgentoo-714d3a1802c59e91297223ee20daeb519c12d476.tar.gz
gentoo-714d3a1802c59e91297223ee20daeb519c12d476.tar.bz2
gentoo-714d3a1802c59e91297223ee20daeb519c12d476.zip
dev-python/defcon: Fix tests
Thanks-to: Thomas Deutschmann Closes: https://bugs.gentoo.org/721156 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/defcon')
-rw-r--r--dev-python/defcon/defcon-0.6.0-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/defcon/defcon-0.6.0-r1.ebuild b/dev-python/defcon/defcon-0.6.0-r1.ebuild
index 9d7deff618ea..b982a24e82b2 100644
--- a/dev-python/defcon/defcon-0.6.0-r1.ebuild
+++ b/dev-python/defcon/defcon-0.6.0-r1.ebuild
@@ -17,8 +17,12 @@ IUSE=""
RDEPEND=">=dev-python/fonttools-3.31.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
-BDEPEND=""
+BDEPEND="
+ test? (
+ dev-python/fonttools[${PYTHON_USEDEP}]
+ dev-python/fs[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests pytest