summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-28 04:46:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-28 04:50:31 +0200
commit6ac494f544f4ac307041cc9e7091b15a190f0835 (patch)
treeaa2222bd9729c72c8f94b5053892233b51268aa1 /dev-python/deprecated/deprecated-1.2.14.ebuild
parentdev-python/asgiref: Bump to 3.7.2 (diff)
downloadgentoo-6ac494f544f4ac307041cc9e7091b15a190f0835.tar.gz
gentoo-6ac494f544f4ac307041cc9e7091b15a190f0835.tar.bz2
gentoo-6ac494f544f4ac307041cc9e7091b15a190f0835.zip
dev-python/deprecated: Bump to 1.2.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/deprecated/deprecated-1.2.14.ebuild')
-rw-r--r--dev-python/deprecated/deprecated-1.2.14.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/deprecated/deprecated-1.2.14.ebuild b/dev-python/deprecated/deprecated-1.2.14.ebuild
new file mode 100644
index 000000000000..f0f289559634
--- /dev/null
+++ b/dev-python/deprecated/deprecated-1.2.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python @deprecated decorator to deprecate old API"
+HOMEPAGE="
+ https://github.com/tantale/deprecated/
+ https://pypi.org/project/Deprecated/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wrapt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest