summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-13 07:49:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-13 08:15:25 +0200
commit986e7caf2a0e515529afa4740167291dd0a04eac (patch)
tree6127b7e0629d773aa588e9f5a6de237c767b0126 /dev-python/deprecated
parentdev-python/googleapis-common-protos: Bump to 1.56.1 (diff)
downloadgentoo-986e7caf2a0e515529afa4740167291dd0a04eac.tar.gz
gentoo-986e7caf2a0e515529afa4740167291dd0a04eac.tar.bz2
gentoo-986e7caf2a0e515529afa4740167291dd0a04eac.zip
dev-python/deprecated: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/deprecated')
-rw-r--r--dev-python/deprecated/deprecated-1.2.13-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/deprecated/deprecated-1.2.13-r1.ebuild b/dev-python/deprecated/deprecated-1.2.13-r1.ebuild
new file mode 100644
index 000000000000..760bc6cccf9f
--- /dev/null
+++ b/dev-python/deprecated/deprecated-1.2.13-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python @deprecated decorator to deprecate old API"
+HOMEPAGE="
+ https://github.com/tantale/deprecated/
+ https://pypi.org/project/deprecated/
+"
+SRC_URI="
+ https://github.com/tantale/deprecated/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wrapt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ tests/test_deprecated.py::test_respect_global_filter
+ tests/test_deprecated_class.py::test_class_respect_global_filter
+ )
+
+ epytest
+}