summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-18 08:02:11 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-18 09:07:34 +0200
commitcbf5e0813c639946e746436fb8d40227d1ef34a5 (patch)
tree1001442b5e41426c1e1afec4f117f92da547152c /dev-python/deprecated
parentsys-kernel/genkernel-next: Bump to v70 (diff)
downloadgentoo-cbf5e0813c639946e746436fb8d40227d1ef34a5.tar.gz
gentoo-cbf5e0813c639946e746436fb8d40227d1ef34a5.tar.bz2
gentoo-cbf5e0813c639946e746436fb8d40227d1ef34a5.zip
dev-python/deprecated: New package
A package to handle deprecations in API. Required for PyGithub bump. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/deprecated')
-rw-r--r--dev-python/deprecated/Manifest1
-rw-r--r--dev-python/deprecated/deprecated-1.2.5.ebuild27
-rw-r--r--dev-python/deprecated/metadata.xml11
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/deprecated/Manifest b/dev-python/deprecated/Manifest
new file mode 100644
index 000000000000..73924199cbe7
--- /dev/null
+++ b/dev-python/deprecated/Manifest
@@ -0,0 +1 @@
+DIST deprecated-1.2.5.gh.tar.gz 5038752 BLAKE2B 82ceadca4ccef4309b2a7d493620cc8a4dd9160ab7449a3019c9e9bc3a99e8016b6125d4165b71813d9543b7629d55372affdbd14ad2c71d101061595bdb677c SHA512 3a16b5d4f2475788ce919c327b668bb8852dab88adfa959826c9b68ccbfba3207a1c60ca164edacde8a756bd3895225af944a51eebde1230a93a973145231234
diff --git a/dev-python/deprecated/deprecated-1.2.5.ebuild b/dev-python/deprecated/deprecated-1.2.5.ebuild
new file mode 100644
index 000000000000..4f502db5e1b9
--- /dev/null
+++ b/dev-python/deprecated/deprecated-1.2.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit distutils-r1
+
+DESCRIPTION="Python @deprecated decorator to deprecate old API"
+HOMEPAGE="https://github.com/tantale/deprecated"
+SRC_URI="https://github.com/tantale/deprecated/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/wrapt[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/deprecated/metadata.xml b/dev-python/deprecated/metadata.xml
new file mode 100644
index 000000000000..22e0d6d87f61
--- /dev/null
+++ b/dev-python/deprecated/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>