summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-24 00:29:51 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-24 00:44:32 +0200
commit27c3aaec24b9f604673bf84e6cafb7d50d0de8fa (patch)
tree895ec387bb4e60728b57f6fd4b40c2ce96e770b6 /dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild
parentdev-python/moto: remove unused dicttoxml dependency (diff)
downloadgentoo-27c3aaec24b9f604673bf84e6cafb7d50d0de8fa.tar.gz
gentoo-27c3aaec24b9f604673bf84e6cafb7d50d0de8fa.tar.bz2
gentoo-27c3aaec24b9f604673bf84e6cafb7d50d0de8fa.zip
dev-python/dicttoxml: enable py3.10
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild')
-rw-r--r--dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild b/dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild
new file mode 100644
index 000000000000..a6882bd19034
--- /dev/null
+++ b/dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Converts a Python dictionary or other data type to a valid XML string"
+HOMEPAGE="https://github.com/quandyfactory/dicttoxml https://pypi.org/project/dicttoxml/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+PATCHES=(
+ # https://github.com/quandyfactory/dicttoxml/pull/73/files
+ "${FILESDIR}/${P}-py3.10.patch"
+)