summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-29 09:48:57 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-29 10:15:34 +0200
commit1cc488af9982d51e10c5d0c552c2fa839a8d7eab (patch)
treedf1348720de8c4782e7f636342e90e1ccf9019fd /dev-python/dill/dill-0.3.0.ebuild
parentdev-python/cloudpickle: Bump to 1.2.1 (diff)
downloadgentoo-1cc488af9982d51e10c5d0c552c2fa839a8d7eab.tar.gz
gentoo-1cc488af9982d51e10c5d0c552c2fa839a8d7eab.tar.bz2
gentoo-1cc488af9982d51e10c5d0c552c2fa839a8d7eab.zip
dev-python/dill: Bump to 0.3.0
Closes: https://bugs.gentoo.org/676912 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dill/dill-0.3.0.ebuild')
-rw-r--r--dev-python/dill/dill-0.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/dill/dill-0.3.0.ebuild b/dev-python/dill/dill-0.3.0.ebuild
new file mode 100644
index 000000000000..2df94b7bb42e
--- /dev/null
+++ b/dev-python/dill/dill-0.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="https://pypi.org/project/dill/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+python_test() {
+ local fail= t
+ for t in tests/test_*.py; do
+ ebegin "\t${t}"
+ "${EPYTHON}" "${t}"
+ eend || fail=1
+ done
+
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}