summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2017-03-22 17:34:01 +0100
committerMarek Szuba <marecki@gentoo.org>2017-03-22 17:35:51 +0100
commitc10f286b7c947e27c9aa10b4ec00b14b3d2326c1 (patch)
tree1a71fb7960c61cacb23fb267e911009cb133814e /dev-python/dirq
parentapp-text/tesseract: do not glob in DISTIDR, bug #612996 (diff)
downloadgentoo-c10f286b7c947e27c9aa10b4ec00b14b3d2326c1.tar.gz
gentoo-c10f286b7c947e27c9aa10b4ec00b14b3d2326c1.tar.bz2
gentoo-c10f286b7c947e27c9aa10b4ec00b14b3d2326c1.zip
dev-python/dirq: new package
A port of Perl module Directory-Queue, developed at CERN. Used by the CERN Puppet librarian Jens. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/dirq')
-rw-r--r--dev-python/dirq/Manifest1
-rw-r--r--dev-python/dirq/dirq-1.7.1.ebuild24
-rw-r--r--dev-python/dirq/metadata.xml20
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/dirq/Manifest b/dev-python/dirq/Manifest
new file mode 100644
index 000000000000..4e1390434b76
--- /dev/null
+++ b/dev-python/dirq/Manifest
@@ -0,0 +1 @@
+DIST dirq-1.7.1.tar.gz 32645 SHA256 258eac86de81fd013f11f309582bdff9f26c76e572214cf291c65c1bc667864c SHA512 8865f395e6ef81131c5e1df9f97cf1768557af06d446a79ece29e23b83c228cbb158099a7e85360423013cd8e5ead8970c5160865f065d16fcc288c2ce9d176f WHIRLPOOL dcd86acf6830f2e843a7691d816115aef7d1c9b9fa0a796bff4559a9d211779ce24ab03ced8ac7b917a35082aa34b1d2de90d480e94ae3db97c4a0e9dea28dd6
diff --git a/dev-python/dirq/dirq-1.7.1.ebuild b/dev-python/dirq/dirq-1.7.1.ebuild
new file mode 100644
index 000000000000..e304075fa727
--- /dev/null
+++ b/dev-python/dirq/dirq-1.7.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python port of Perl module Directory::Queue"
+HOMEPAGE="https://github.com/cern-mig/python-dirq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+# Note: as of 2017-03-22, dirq tests are known to fail in Docker containers
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/dirq/metadata.xml b/dev-python/dirq/metadata.xml
new file mode 100644
index 000000000000..2e025c6c0714
--- /dev/null
+++ b/dev-python/dirq/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription lang="en">
+ The goal of this module is to offer a queue system using the underlying
+ filesystem for storage, security and to prevent race conditions via
+ atomic operations. It focuses on simplicity, robustness and scalability.
+
+ This module allows multiple concurrent readers and writers to interact
+ with the same queue.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">cern-mig/python-dirq</remote-id>
+ <remote-id type="pypi">dirq</remote-id>
+ </upstream>
+</pkgmetadata>