summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-24 08:20:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-24 08:25:17 +0200
commitd622d6b77e40bbec9ef8f403a741b84e18665213 (patch)
treeb17dd601933a31e8b318b5f5d919fa42f58e3ed0 /dev-python/diskcache/diskcache-5.0.1.ebuild
parentdev-python/arrow: Bump to 0.16.0 (diff)
downloadgentoo-d622d6b77e40bbec9ef8f403a741b84e18665213.tar.gz
gentoo-d622d6b77e40bbec9ef8f403a741b84e18665213.tar.bz2
gentoo-d622d6b77e40bbec9ef8f403a741b84e18665213.zip
dev-python/diskcache: Bump to 5.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/diskcache/diskcache-5.0.1.ebuild')
-rw-r--r--dev-python/diskcache/diskcache-5.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/diskcache/diskcache-5.0.1.ebuild b/dev-python/diskcache/diskcache-5.0.1.ebuild
new file mode 100644
index 000000000000..c07ed748a131
--- /dev/null
+++ b/dev-python/diskcache/diskcache-5.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="http://www.grantjenks.com/docs/diskcache/
+ https://github.com/grantjenks/python-diskcache/"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="
+ https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/python-diskcache-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove dep on pytest-xdist
+ sed -i -e '/-n auto/d' tox.ini || die
+
+ distutils-r1_src_prepare
+}