summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-09 09:10:00 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-09 09:14:51 +0100
commit44aab32f3238f9ddcfcefed0e7d0ba8a75ec689e (patch)
tree89a1c08821f25a182be4cef8701c2ca32e09bdcc /dev-python/diskcache
parentdev-python/sortedcontainers: Bump to 2.3.0 (diff)
downloadgentoo-44aab32f3238f9ddcfcefed0e7d0ba8a75ec689e.tar.gz
gentoo-44aab32f3238f9ddcfcefed0e7d0ba8a75ec689e.tar.bz2
gentoo-44aab32f3238f9ddcfcefed0e7d0ba8a75ec689e.zip
dev-python/diskcache: Bump to 5.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/diskcache')
-rw-r--r--dev-python/diskcache/Manifest1
-rw-r--r--dev-python/diskcache/diskcache-5.1.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
index d82cad07665f..8044b48d5efe 100644
--- a/dev-python/diskcache/Manifest
+++ b/dev-python/diskcache/Manifest
@@ -1 +1,2 @@
DIST diskcache-5.0.3.gh.tar.gz 656486 BLAKE2B be3a7c919287698e4bd7fc6ff4b861729eabeddff47d01f08711f75f72a48d652e798ed511c5aa1cd9952ecbbbd5ebb003663cfd9c0877b812ef421665e080c0 SHA512 41b393ce255747939c68059251c31b5af43ad9c7fbcfe9288193c501a3a7d070b8db0863e1abd10f16db574565719b2357a7b10371428ed3f37f7de754b16ab6
+DIST diskcache-5.1.0.gh.tar.gz 656930 BLAKE2B 19ec1e16e33315248f28e1937a94bb29d641f31c263a3a2fc4d24b58082f7c9c522c74f38d07ece51dce066040538ef47348c50e8d591a749674ab6d6f2ce5f1 SHA512 33437899221051ef3dafd0eeddfec72bef00d5a6b189046cb919495b322b534445a39e5d23a1c85484867d9d07efb7de36fe5f2d3dad79357086a3dcfa3c8b0c
diff --git a/dev-python/diskcache/diskcache-5.1.0.ebuild b/dev-python/diskcache/diskcache-5.1.0.ebuild
new file mode 100644
index 000000000000..c57b662ad91a
--- /dev/null
+++ b/dev-python/diskcache/diskcache-5.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="http://www.grantjenks.com/docs/diskcache/
+ https://github.com/grantjenks/python-diskcache/"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="
+ https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/python-diskcache-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove dep on pytest-xdist
+ sed -i -e '/-n auto/d' tox.ini || die
+
+ distutils-r1_src_prepare
+}