summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-21 10:03:18 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-21 10:08:17 +0200
commitc67df0e39a9dc978f1cf039f46c27157364bf929 (patch)
tree2e2114b5a05a296498d77fbd7c425561c157532a /dev-python/diskcache
parentdev-python/discogs-client: Bump to 2.2.2 (diff)
downloadgentoo-c67df0e39a9dc978f1cf039f46c27157364bf929.tar.gz
gentoo-c67df0e39a9dc978f1cf039f46c27157364bf929.tar.bz2
gentoo-c67df0e39a9dc978f1cf039f46c27157364bf929.zip
dev-python/diskcache: Bump to 4.1.0, py3.{7,8}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/diskcache')
-rw-r--r--dev-python/diskcache/Manifest1
-rw-r--r--dev-python/diskcache/diskcache-4.1.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
index 5cf476e6d6b0..a6fee4ee6738 100644
--- a/dev-python/diskcache/Manifest
+++ b/dev-python/diskcache/Manifest
@@ -1 +1,2 @@
DIST diskcache-3.1.0.tar.gz 489821 BLAKE2B 56b54662f31172f4f746ce885d57a3e9f34af9d7318300fe6906aee1b3373919f6ee33922ab30b7979cc6e271f2f780894438b4114483a7c76f198fb7b2213c1 SHA512 30ea3e6c1ed6430c1a7e3bf022bd9233e89a2486308d1f48f6e2f0b50ccc1ee50dade7c55d98a5611ef384bd193cd28f7e65f5737bae00845b17c159177dd345
+DIST diskcache-4.1.0.gh.tar.gz 658268 BLAKE2B 7712892a15e0f7b34b05c48071b4ed22f94ff4c8b6e66dff5591296d7186c686958ef3ec19994b6965319ba3e601850a1782f7ac8ed09090afda4b75ae16a12b SHA512 3871e56fa9a50942e29e200df74d7f4312d21a0f51d6be2041ce71efd3c1d0c204cc1df5ac1f92825314c742bb48bf8b0a3929cee225055903953e095701c8e3
diff --git a/dev-python/diskcache/diskcache-4.1.0.ebuild b/dev-python/diskcache/diskcache-4.1.0.ebuild
new file mode 100644
index 000000000000..36f1dadb1212
--- /dev/null
+++ b/dev-python/diskcache/diskcache-4.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="http://www.grantjenks.com/docs/diskcache/
+ https://github.com/grantjenks/python-diskcache/"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="
+ https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/python-diskcache-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove dep on pytest-xdist
+ sed -i -e '/-n auto/d' tox.ini || die
+ # requires django-1.1*
+ rm diskcache/djangocache.py || die
+ sed -e '/diskcache\.djangocache/d' \
+ -e 's:test_djangocache:_&:' \
+ -i tests/test_doctest.py || die
+ rm tests/test_djangocache.py || die
+
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ elog "Please note that the Gentoo package does not install the djangocache"
+ elog "submodule as it requires old version of dev-python/django."
+}