summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-25 21:03:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-25 21:03:33 +0300
commit722232c6fbcbbea9fa46aa6aecc96221581fb5c1 (patch)
tree66782968dd15b4a3b4ecef70121b67ec7d413762 /dev-python/distlib
parentdev-python/distlib: Stabilize 0.3.6 ALLARCHES, #872947 (diff)
downloadgentoo-722232c6fbcbbea9fa46aa6aecc96221581fb5c1.tar.gz
gentoo-722232c6fbcbbea9fa46aa6aecc96221581fb5c1.tar.bz2
gentoo-722232c6fbcbbea9fa46aa6aecc96221581fb5c1.zip
dev-python/distlib: drop 0.3.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/distlib')
-rw-r--r--dev-python/distlib/Manifest1
-rw-r--r--dev-python/distlib/distlib-0.3.5.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/distlib/Manifest b/dev-python/distlib/Manifest
index 435ee6f1a47c..8b5f107343c5 100644
--- a/dev-python/distlib/Manifest
+++ b/dev-python/distlib/Manifest
@@ -1,2 +1 @@
-DIST distlib-0.3.5.gh.tar.gz 1233989 BLAKE2B 616666e835aa201ceeeb423452a25adafab67dc20f99496b711e3ca6d4916f4e1dd39e444b1c8824e90559e898fc0588cd58d2d5be07af172d6b6ed3f3c7fe4c SHA512 927861d2e11785d8419c3125784f21ee052883c03d91d8893d2c77b47739e45cbca39e5d90446e906c71744bd57274192b28af86def239a16caeae4d3887d5a6
DIST distlib-0.3.6.gh.tar.gz 1234082 BLAKE2B 384b736d9fb9e63d1b9a9375caf972ddfccb36c99903928505e684fe09b30190f873cf7b109beb6c32a1e4b1e11a1d9947adea74f9dceef3398fcc1963a2044a SHA512 39948539764ff5d45f14dc602ebd47d523b71b587ee081d7a267669aef4e4b1013d3995cb992038136bc4c01826ea633c6e4ffd050f1511705b296bf76f3bbf9
diff --git a/dev-python/distlib/distlib-0.3.5.ebuild b/dev-python/distlib/distlib-0.3.5.ebuild
deleted file mode 100644
index bacb469be379..000000000000
--- a/dev-python/distlib/distlib-0.3.5.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Low-level components of distutils2/packaging"
-HOMEPAGE="
- https://pypi.org/project/distlib/
- https://github.com/pypa/distlib
-"
-SRC_URI="
- https://github.com/pypa/distlib/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# pypiserver is called as external executable
-# openpyxl installs invalid metadata that breaks distlib
-BDEPEND="
- test? (
- dev-python/pypiserver
- !!<dev-python/openpyxl-3.0.3[${PYTHON_USEDEP}]
- )
-"
-
-src_prepare() {
- # make sure they're not used
- rm tests/pypi-server-standalone.py || die
-
- # use system pypiserver instead of broken bundled one
- eapply "${FILESDIR}"/distlib-0.3.2-system-pypiserver.py || die
-
- # doesn't work with our patched pip
- sed -i -e '/PIP_AVAIL/s:True:False:' tests/test_wheel.py || die
-
- # broken with pypy3
- sed -i -e 's:test_custom_shebang:_&:' tests/test_scripts.py || die
- # broken with py3.11, doesn't look important
- sed -i -e 's:test_sequencer_basic:_&:' tests/test_util.py || die
- # https://bugs.gentoo.org/843839
- sed -i -e 's:test_interpreter_args:_&:' tests/test_scripts.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x SKIP_ONLINE=1
- local -x PYTHONHASHSEED=0
-
- # disable system-site-packages -- distlib has no deps, and is very
- # fragile to packages actually installed on the system
- sed -i -e '/system-site-packages/s:true:false:' \
- "${BUILD_DIR}/install${EPREFIX}/usr/bin/pyvenv.cfg" || die
-
- "${EPYTHON}" tests/test_all.py -v -x ||
- die "Tests failed with ${EPYTHON}"
-}