summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-06-04 07:45:53 +0100
committerJustin Lecher <jlec@gentoo.org>2017-06-04 08:30:20 +0100
commit6808e1118b938a742dd649bcb24fb111b3449038 (patch)
treedaf31bc393d7793f24bfc1f6e32ee98a3ad5c554 /dev-python/dj-database-url/dj-database-url-0.4.2.ebuild
parentdev-python/python-memcached: Add python 3.6 support (diff)
downloadgentoo-6808e1118b938a742dd649bcb24fb111b3449038.tar.gz
gentoo-6808e1118b938a742dd649bcb24fb111b3449038.tar.bz2
gentoo-6808e1118b938a742dd649bcb24fb111b3449038.zip
dev-python/dj-database-url: Version Bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/dj-database-url/dj-database-url-0.4.2.ebuild')
-rw-r--r--dev-python/dj-database-url/dj-database-url-0.4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/dj-database-url/dj-database-url-0.4.2.ebuild b/dev-python/dj-database-url/dj-database-url-0.4.2.ebuild
new file mode 100644
index 000000000000..0d4fc785818f
--- /dev/null
+++ b/dev-python/dj-database-url/dj-database-url-0.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Use Database URLs in your Django Application"
+HOMEPAGE="
+ https://pypi.python.org/pypi/dj-database-url
+ https://github.com/kennethreitz/dj-database-url"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Not contained in the tarball
+RESTRICT=test
+
+python_test() {
+ "${PYTHON}" test_dj_database_url.py || die
+}