summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-01-26 13:56:11 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-01-26 13:56:11 -0600
commit0f23fad3104733da6d491c611a45aeb812e89b41 (patch)
treef9411e93800f2098ffa960c394c01f837036da8f /dev-python/django-auth-ldap/django-auth-ldap-2.1.0.ebuild
parentdev-python/virtualenv: Regen Manifest (diff)
downloadgentoo-0f23fad3104733da6d491c611a45aeb812e89b41.tar.gz
gentoo-0f23fad3104733da6d491c611a45aeb812e89b41.tar.bz2
gentoo-0f23fad3104733da6d491c611a45aeb812e89b41.zip
dev-python/django-auth-ldap: 2.1.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/django-auth-ldap/django-auth-ldap-2.1.0.ebuild')
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-2.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-2.1.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-2.1.0.ebuild
new file mode 100644
index 000000000000..2dcefcb72c1b
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="https://pypi.org/project/django-auth-ldap/ https://bitbucket.org/psagers/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}