summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-16 09:23:41 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-16 09:30:08 +0200
commit8683c82018b4934b39dfba011558c8a516aadc4c (patch)
tree76b9833962b4b72608b73ecce2ea66227ddabefe /dev-python/django-cors-headers/django-cors-headers-3.8.0.ebuild
parentdev-python/iminuit: Bump to 2.8.2 (diff)
downloadgentoo-8683c82018b4934b39dfba011558c8a516aadc4c.tar.gz
gentoo-8683c82018b4934b39dfba011558c8a516aadc4c.tar.bz2
gentoo-8683c82018b4934b39dfba011558c8a516aadc4c.zip
dev-python/django-cors-headers: Bump to 3.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-cors-headers/django-cors-headers-3.8.0.ebuild')
-rw-r--r--dev-python/django-cors-headers/django-cors-headers-3.8.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/django-cors-headers/django-cors-headers-3.8.0.ebuild b/dev-python/django-cors-headers/django-cors-headers-3.8.0.ebuild
new file mode 100644
index 000000000000..441ad19af723
--- /dev/null
+++ b/dev-python/django-cors-headers/django-cors-headers-3.8.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses"
+HOMEPAGE="https://github.com/adamchainz/django-cors-headers"
+SRC_URI="
+ https://github.com/adamchainz/django-cors-headers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/django-2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest