summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-14 20:50:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-14 20:50:09 +0100
commit2576227bd2e0642dd4f2d3570b2c85b84c3b2aee (patch)
treedd46a814260f82be3d8bcb59a935aba7f84059fa /dev-python/django-cors-headers/django-cors-headers-4.3.1.ebuild
parentdev-python/mkdocstrings: Bump to 0.24.0 (diff)
downloadgentoo-2576227bd2e0642dd4f2d3570b2c85b84c3b2aee.tar.gz
gentoo-2576227bd2e0642dd4f2d3570b2c85b84c3b2aee.tar.bz2
gentoo-2576227bd2e0642dd4f2d3570b2c85b84c3b2aee.zip
dev-python/django-cors-headers: Bump to 4.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-cors-headers/django-cors-headers-4.3.1.ebuild')
-rw-r--r--dev-python/django-cors-headers/django-cors-headers-4.3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/django-cors-headers/django-cors-headers-4.3.1.ebuild b/dev-python/django-cors-headers/django-cors-headers-4.3.1.ebuild
new file mode 100644
index 000000000000..c7f8d2fb4df3
--- /dev/null
+++ b/dev-python/django-cors-headers/django-cors-headers-4.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses"
+HOMEPAGE="
+ https://github.com/adamchainz/django-cors-headers/
+ https://pypi.org/project/django-cors-headers/
+"
+SRC_URI="
+ https://github.com/adamchainz/django-cors-headers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/asgiref-3.6[${PYTHON_USEDEP}]
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest