summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-06 07:21:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-06 07:26:51 +0200
commitaa7e7ba7c7b0f02ddd7e8927a52b931ff9486429 (patch)
tree785a914658b2f4efcfd614723615b3b054c7a352 /dev-python/django-cors-headers
parentdev-python/qtconsole: Bump to 5.3.1 (diff)
downloadgentoo-aa7e7ba7c7b0f02ddd7e8927a52b931ff9486429.tar.gz
gentoo-aa7e7ba7c7b0f02ddd7e8927a52b931ff9486429.tar.bz2
gentoo-aa7e7ba7c7b0f02ddd7e8927a52b931ff9486429.zip
dev-python/django-cors-headers: Bump to 3.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-cors-headers')
-rw-r--r--dev-python/django-cors-headers/Manifest1
-rw-r--r--dev-python/django-cors-headers/django-cors-headers-3.13.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/django-cors-headers/Manifest b/dev-python/django-cors-headers/Manifest
index eebc813a490c..948a376d3081 100644
--- a/dev-python/django-cors-headers/Manifest
+++ b/dev-python/django-cors-headers/Manifest
@@ -1 +1,2 @@
DIST django-cors-headers-3.12.0.gh.tar.gz 26638 BLAKE2B 7725f7db4e9a67d7cd7f4add74abb5bfd27bac4c65cf4120dee3ba412c27fd89d6e39502249ea4b253c6a7d7d0f5328296ed69ac8b3ceb337bbb89a04f93a6ce SHA512 16d1d03bf1f5336703168280ff585168eb239f454aaec1f1e9928a362c7e7da17b54e896d7428ecdc91657045bede0b3c239a7f2f271c58c1b7b265b2e52aef5
+DIST django-cors-headers-3.13.0.gh.tar.gz 27361 BLAKE2B 2d0729ae6f0e0ff7c572c5f25482fd88dfa03e8f03a7f640ba32f56208fccb91712cd3067bc3376428469cc7f03dd8003069b79e98dd438fad9e5f4b15cd9c71 SHA512 153ae0d2e0b1e390c72993ca629f7ed521fd907481bb2944ee2f805c0081a1db334fd72f0b3fdb77cbb57b3392691f32564bb646bfb8e388a942a8a3da138a8e
diff --git a/dev-python/django-cors-headers/django-cors-headers-3.13.0.ebuild b/dev-python/django-cors-headers/django-cors-headers-3.13.0.ebuild
new file mode 100644
index 000000000000..11302037f21b
--- /dev/null
+++ b/dev-python/django-cors-headers/django-cors-headers-3.13.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses"
+HOMEPAGE="
+ https://github.com/adamchainz/django-cors-headers/
+ https://pypi.org/project/django-cors-headers/
+"
+SRC_URI="
+ https://github.com/adamchainz/django-cors-headers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest