summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-03-19 22:55:39 +0100
committerDavid Seifert <soap@gentoo.org>2020-03-19 22:55:39 +0100
commit6aca328b0aec47b517003289b2d8351093fa3885 (patch)
tree104226db65e9a242dee133bcc1f97ed498bf9541 /dev-python/django-debug-toolbar/django-debug-toolbar-2.1.ebuild
parentdev-python/websocket-client: Remove old (diff)
downloadgentoo-6aca328b0aec47b517003289b2d8351093fa3885.tar.gz
gentoo-6aca328b0aec47b517003289b2d8351093fa3885.tar.bz2
gentoo-6aca328b0aec47b517003289b2d8351093fa3885.zip
dev-python/django-debug-toolbar: Remove old
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/django-debug-toolbar/django-debug-toolbar-2.1.ebuild')
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-2.1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-2.1.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-2.1.ebuild
deleted file mode 100644
index 3b1d9adcb3b9..000000000000
--- a/dev-python/django-debug-toolbar/django-debug-toolbar-2.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="A configurable set of panels that display debug information"
-HOMEPAGE="
- https://pypi.org/project/django-debug-toolbar/
- https://github.com/django-debug-toolbar/django-debug-toolbar/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-RDEPEND="
- >=dev-python/django-1.11[${PYTHON_USEDEP}]
- >=dev-python/sqlparse-0.2.0[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- # Prevent non essential d'loading by intersphinx
- sed -e 's:intersphinx_mapping:_&:' -i docs/conf.py || die
-
- # This prevents distutils from installing 'tests' package, rm magic no more needed
- sed -e "/find_packages/s:'tests':'tests.\*', 'tests':" -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- emake test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( example/. )
- distutils-r1_python_install_all
-}