summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-15 08:27:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-15 08:32:07 +0200
commit99e945fc723eba5791a56ab1f5ec05f892503a20 (patch)
treed69cae18a4712f7d0b08a58fa08c14c6e0f88158 /dev-python/django-debug-toolbar
parentdev-python/requests-cache: Bump to 0.6.2 (diff)
downloadgentoo-99e945fc723eba5791a56ab1f5ec05f892503a20.tar.gz
gentoo-99e945fc723eba5791a56ab1f5ec05f892503a20.tar.bz2
gentoo-99e945fc723eba5791a56ab1f5ec05f892503a20.zip
dev-python/django-debug-toolbar: Bump to 3.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest1
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-3.2.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index c707abcbdfff..b900f9ce820d 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1 +1,2 @@
DIST django-debug-toolbar-3.1.tar.gz 228867 BLAKE2B af3d8011136ba30e690e03548d757405e9cd89fb5473b277720a3151149e92be212e50a6ec3d95903382716c9594405a1e93a7a1bf231f220f4b5c8ae1e38480 SHA512 c4cfa3cd98adfba7362e259e18a0240b886f294ba10f5c64e12887b00d4dc952e9b80cac0f78e7193a15566585f43d988f6d287e4d0dcc84c4f8395c7006e2b0
+DIST django-debug-toolbar-3.2.1.tar.gz 231177 BLAKE2B b07ed03a92b5799dafd1b15b41335c5da6994be1001b579c85e0923ccc092e617ce04c9a2f4344716213cdd62425737838a8539ca5b566928bf8b4c133e8451e SHA512 d28e13cc2e3bbb27e9c728037229adac444180e3831b88c9ac1aa0e139bd1e85f9190c7a324afe3292bde4ad0c919bd17fbde4998be266f81314b9b22c4a28e6
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.1.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.1.ebuild
new file mode 100644
index 000000000000..06f03d13eb93
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.org/project/django-debug-toolbar/
+ https://github.com/jazzband/django-debug-toolbar/"
+SRC_URI="https://github.com/jazzband/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ emake TEST_ARGS='-v 2 tests' test
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}