summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2016-01-16 16:14:21 +0100
committerJohann Schmitz <ercpe@gentoo.org>2016-01-16 16:14:21 +0100
commit983d14cf18efbac8551d3ff484fe0f94ae144a50 (patch)
tree0772dc3cebae60299757ecb295bd2346e42b58d5 /dev-python/django-otp/django-otp-0.3.4.ebuild
parentsci-libs/nlopt: Add patch for octave-4.0.0 (diff)
downloadgentoo-983d14cf18efbac8551d3ff484fe0f94ae144a50.tar.gz
gentoo-983d14cf18efbac8551d3ff484fe0f94ae144a50.tar.bz2
gentoo-983d14cf18efbac8551d3ff484fe0f94ae144a50.zip
dev-python/django-otp: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/django-otp/django-otp-0.3.4.ebuild')
-rw-r--r--dev-python/django-otp/django-otp-0.3.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/django-otp/django-otp-0.3.4.ebuild b/dev-python/django-otp/django-otp-0.3.4.ebuild
new file mode 100644
index 000000000000..ffa3458685e5
--- /dev/null
+++ b/dev-python/django-otp/django-otp-0.3.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Framework for adding two-factor authentication to Django using one-time passwords"
+HOMEPAGE="https://bitbucket.org/psagers/django-otp"
+SRC_URI="mirror://pypi/d/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/django-1.4.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"