summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2020-03-10 11:57:34 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-03-10 11:57:34 -0500
commit813ecd217de998b18bd0dc7174c7c017dc0bceb6 (patch)
treef4de6362349334ff1a972a4978fb4e31a166b270 /dev-python/django-pglocks/django-pglocks-1.0.4.ebuild
parentRevert "profiles: Unmask Python 3.7 targets from stable for x86" (diff)
downloadgentoo-813ecd217de998b18bd0dc7174c7c017dc0bceb6.tar.gz
gentoo-813ecd217de998b18bd0dc7174c7c017dc0bceb6.tar.bz2
gentoo-813ecd217de998b18bd0dc7174c7c017dc0bceb6.zip
dev-python/django-pglocks: context managers for advisory locks for pgsql
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/django-pglocks/django-pglocks-1.0.4.ebuild')
-rw-r--r--dev-python/django-pglocks/django-pglocks-1.0.4.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/django-pglocks/django-pglocks-1.0.4.ebuild b/dev-python/django-pglocks/django-pglocks-1.0.4.ebuild
new file mode 100644
index 000000000000..57f5a7238478
--- /dev/null
+++ b/dev-python/django-pglocks/django-pglocks-1.0.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="PostgreSQL locking context managers and functions for Django"
+HOMEPAGE="https://github.com/Xof/django-pglocks"
+SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-python/six-1.0.0[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}"
+