summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-07-15 17:15:58 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-07-15 17:17:30 -0500
commite9bc478ec8e7431a862a441010e46497e9e81fb3 (patch)
treee14cdc38173adf954316f61d5821f1a0822f149e /dev-python/django-prometheus/django-prometheus-1.0.15.ebuild
parentsci-libs/sundials: fix patches (diff)
downloadgentoo-e9bc478ec8e7431a862a441010e46497e9e81fb3.tar.gz
gentoo-e9bc478ec8e7431a862a441010e46497e9e81fb3.tar.bz2
gentoo-e9bc478ec8e7431a862a441010e46497e9e81fb3.zip
dev-python/django-prometheus: export django metrics to prometheus
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/django-prometheus/django-prometheus-1.0.15.ebuild')
-rw-r--r--dev-python/django-prometheus/django-prometheus-1.0.15.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/django-prometheus/django-prometheus-1.0.15.ebuild b/dev-python/django-prometheus/django-prometheus-1.0.15.ebuild
new file mode 100644
index 000000000000..fe4f69261888
--- /dev/null
+++ b/dev-python/django-prometheus/django-prometheus-1.0.15.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Library to export django metrics for prometheus"
+HOMEPAGE="https://github.com/korfuri/django-prometheus"
+SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+
+LICENSE="Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-python/prometheus_client-0.0.21[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"