summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-23 20:09:15 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-23 20:10:41 +0200
commit3563b4015e4f0b2a2d69772c148eb83746c7e931 (patch)
tree0f25963fff1d965f0bc9dda448bba9a6d0898887 /dev-python/django-sortedm2m
parentsys-devel/kgcc64: sync versions and patches with sys-deve/gcc (diff)
downloadgentoo-3563b4015e4f0b2a2d69772c148eb83746c7e931.tar.gz
gentoo-3563b4015e4f0b2a2d69772c148eb83746c7e931.tar.bz2
gentoo-3563b4015e4f0b2a2d69772c148eb83746c7e931.zip
dev-python/django-sortedm2m: Bump to 3.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-sortedm2m')
-rw-r--r--dev-python/django-sortedm2m/Manifest1
-rw-r--r--dev-python/django-sortedm2m/django-sortedm2m-3.0.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/django-sortedm2m/Manifest b/dev-python/django-sortedm2m/Manifest
index 21fe41bf36d0..6921e43906f1 100644
--- a/dev-python/django-sortedm2m/Manifest
+++ b/dev-python/django-sortedm2m/Manifest
@@ -1,2 +1,3 @@
DIST django-sortedm2m-2.0.0.gh.tar.gz 44491 BLAKE2B f6fb1e8678a47881a52fa8dc65bd16b97871c9a711f6dd604c3293b6f77f943f3fc797c3dcebc43db7c6982d8bae8dbfbf7ae6d7904bd17309d6bd0a833083e3 SHA512 207abbe3ca9b46a26a8a6cea278c87a72990577afeaced347aa9c020a15fd8a384491f2c027d811ee96633cdafd23e2ab841b4cc90d88119415a71cf4860bb96
DIST django-sortedm2m-3.0.1.gh.tar.gz 44262 BLAKE2B 0cfa2babf252423b23db4085a30536960727a71e7e01d740b8d433cf446fead039101d461a839cdbd861b23963897387dbf57ff4027a8956263a04f1f66d6368 SHA512 532c4c3260d52d1cc8052d7253f26c1783329ab8dc031542539fbce0d3e9ca08c91db60f3065ea9047fd8d2c2ac77a27ab8983d6fd4203cae512bfcb6ce877b0
+DIST django-sortedm2m-3.0.2.gh.tar.gz 44296 BLAKE2B 41dd4a7bc654fef638f7a387b1307ee32ca2d8733f4ba6b9fffc92a9ab4c6af7d64159cd5a24f4305483502609a1730fe12a3072f493251840ba840b98155877 SHA512 4e58ff37cdd798d88c47a8efee2bc783ad7109b30e023127345b6d12b176e452d6125fbcaba5392fc11660df3e8b66be4b23d5ff7ab90020f946cfedc80276a7
diff --git a/dev-python/django-sortedm2m/django-sortedm2m-3.0.2.ebuild b/dev-python/django-sortedm2m/django-sortedm2m-3.0.2.ebuild
new file mode 100644
index 000000000000..1c4c012dae9b
--- /dev/null
+++ b/dev-python/django-sortedm2m/django-sortedm2m-3.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for django's many to many field with sorted relations"
+HOMEPAGE="https://pypi.org/project/django-sortedm2m/
+ https://github.com/jazzband/django-sortedm2m"
+SRC_URI="
+ https://github.com/jazzband/django-sortedm2m/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )"
+
+python_test() {
+ local -x PYTHONPATH=test_project:${PYTHONPATH}
+ django-admin test -v 2 --settings=settings --noinput sortedm2m_tests ||
+ die "Tests fail with ${EPYTHON}"
+}