summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-21 16:03:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-21 16:20:34 +0200
commit60d8aefa58bedb7332c9bd100babd3c523a70870 (patch)
tree320d3218481ca187ecf60808fc756c178d5e5fa8 /dev-python/django-sortedm2m
parentdev-libs/openssl: bump to v1.1.1g (diff)
downloadgentoo-60d8aefa58bedb7332c9bd100babd3c523a70870.tar.gz
gentoo-60d8aefa58bedb7332c9bd100babd3c523a70870.tar.bz2
gentoo-60d8aefa58bedb7332c9bd100babd3c523a70870.zip
dev-python/django-sortedm2m: Bump to 2.0.0, py3.{7,8}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-sortedm2m')
-rw-r--r--dev-python/django-sortedm2m/Manifest1
-rw-r--r--dev-python/django-sortedm2m/django-sortedm2m-2.0.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/django-sortedm2m/Manifest b/dev-python/django-sortedm2m/Manifest
index d1cf6cd58854..32b1572802aa 100644
--- a/dev-python/django-sortedm2m/Manifest
+++ b/dev-python/django-sortedm2m/Manifest
@@ -1 +1,2 @@
DIST django-sortedm2m-1.3.2.tar.gz 36246 BLAKE2B c794373d3555010778727146717778130b311d3c1869f0539b07980de2222d69c1ad4dd508cf35da32f4f55af0ea6cbc0d322de40454548dc59f156ae7856f4f SHA512 3695cc0a565a6e1d47e3573dce1f8c860f78c8d11d248634a8ffd6534c621e7575b2333b7a83e6c521e6e737d7ffc67ce1bbcc8504542751d3cfb254b3d98584
+DIST django-sortedm2m-2.0.0.gh.tar.gz 44491 BLAKE2B f6fb1e8678a47881a52fa8dc65bd16b97871c9a711f6dd604c3293b6f77f943f3fc797c3dcebc43db7c6982d8bae8dbfbf7ae6d7904bd17309d6bd0a833083e3 SHA512 207abbe3ca9b46a26a8a6cea278c87a72990577afeaced347aa9c020a15fd8a384491f2c027d811ee96633cdafd23e2ab841b4cc90d88119415a71cf4860bb96
diff --git a/dev-python/django-sortedm2m/django-sortedm2m-2.0.0.ebuild b/dev-python/django-sortedm2m/django-sortedm2m-2.0.0.ebuild
new file mode 100644
index 000000000000..f513c330485d
--- /dev/null
+++ b/dev-python/django-sortedm2m/django-sortedm2m-2.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for django's many to many field with sorted relations"
+HOMEPAGE="https://pypi.org/project/django-sortedm2m/
+ https://github.com/jazzband/django-sortedm2m"
+SRC_URI="
+ https://github.com/jazzband/django-sortedm2m/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_test() {
+ local -x PYTHONPATH=test_project:${PYTHONPATH}
+ django-admin test -v 2 --settings=settings --noinput sortedm2m_tests ||
+ die "Tests fail with ${EPYTHON}"
+}