summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-08 08:48:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-08 08:55:29 +0200
commit40798293a378bb6890eedf0ab9bd2063a0cf2ed5 (patch)
treeae107a50926059ad1e2e71124e8a298ddaf6880e /dev-python/django-timezone-field/django-timezone-field-4.2.1.ebuild
parentdev-python/djangorestframework: Port to py3.10 (diff)
downloadgentoo-40798293a378bb6890eedf0ab9bd2063a0cf2ed5.tar.gz
gentoo-40798293a378bb6890eedf0ab9bd2063a0cf2ed5.tar.bz2
gentoo-40798293a378bb6890eedf0ab9bd2063a0cf2ed5.zip
dev-python/django-timezone-field: Bump to 4.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-timezone-field/django-timezone-field-4.2.1.ebuild')
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-4.2.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/django-timezone-field/django-timezone-field-4.2.1.ebuild b/dev-python/django-timezone-field/django-timezone-field-4.2.1.ebuild
new file mode 100644
index 000000000000..0e61159b2c1e
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-4.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for pytz timezone objects"
+HOMEPAGE="https://github.com/mfogel/django-timezone-field"
+SRC_URI="
+ https://github.com/mfogel/django-timezone-field/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DB_ENGINE=sqlite
+ epytest
+}