summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-05-13 16:34:18 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-05-13 16:34:18 +0200
commitec47d2bbaf2be8eb8e5eb80ed0bdd77c7dc0bb30 (patch)
tree393019c4bc0f64add8100a69262c60863e741b61 /dev-python/dnspython
parentnet-wireless/iwd: drop old (diff)
downloadgentoo-ec47d2bbaf2be8eb8e5eb80ed0bdd77c7dc0bb30.tar.gz
gentoo-ec47d2bbaf2be8eb8e5eb80ed0bdd77c7dc0bb30.tar.bz2
gentoo-ec47d2bbaf2be8eb8e5eb80ed0bdd77c7dc0bb30.zip
dev-python/dnspython: Version bump to 1.16.0
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest1
-rw-r--r--dev-python/dnspython/dnspython-1.16.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index 23080a5bc5f8..71fbab977087 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,2 +1,3 @@
DIST dnspython-1.15.0.zip 252157 BLAKE2B 6766c1e69bc4225b08f3b1b3871fac2aba7ae707de5f16718798ce4d6846308500c5341f9ace1b48d3858ffc965a7295ee42cc2c35ff23ac38d71927dcaecfe9 SHA512 942f7cf083d1b0a9f03f040ceca194c38777f2e40862c388051986112b3f2a4a8426733ff46ec5a155319776e4a856412c3430b052b2f92f251f0e3260eb9bc1
+DIST dnspython-1.16.0.tar.gz 167172 BLAKE2B a246684aae8651d94b4312a4b4cce2236a0c4f2289a8fe8a2bb8e81c6beddf6e81a7d54928bc50f950fde862b27e589e83fa9f7aaff7d263a6442f47fe9bb3bb SHA512 825a1815855e036ea1dfece6ec0d42242f83163960439ecba3da58d9adb85b65dda7e628cf38c386807a6c0c36aa026d5e95f7a1bdc2927aa2f6f042f873c14c
DIST dnspython-1.16.0_pre20180731.tar.gz 182538 BLAKE2B 3a472091fccc4f37d65681727643677472837fd6be0c4fd6aaa13afd1fd4362eb27a5ba4ff6babca46fe15c2f5318ddbba22ce058b522f763baa797e1e2d1ab9 SHA512 67d17ab7cb48c370c3c2dd5cb935eec5ab7e3ac0c912e179931f395899ad186ba869edd8b870c043ba9fb3545bace18549d2a377f2ae2c278660fc488e68a20d
diff --git a/dev-python/dnspython/dnspython-1.16.0.ebuild b/dev-python/dnspython/dnspython-1.16.0.ebuild
new file mode 100644
index 000000000000..99bce355fb93
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.16.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ https://pypi.org/project/dnspython/"
+SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/ecdsa-0.13[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.1[${PYTHON_USEDEP}]
+ !dev-python/dnspython:py2
+ !dev-python/dnspython:py3"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# For testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
+ einfo "Testsuite passed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}