summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-23 17:39:31 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-23 18:05:15 +0100
commit3da8c4d94cf9f9ae8c3a81c4c73cf23ece1866d5 (patch)
tree6e94e4e0fd092b7587a07672bd2abcd9fb738a42 /dev-python/docker-py
parentdev-python/virtualenv: Bump to 20.2.1 (diff)
downloadgentoo-3da8c4d94cf9f9ae8c3a81c4c73cf23ece1866d5.tar.gz
gentoo-3da8c4d94cf9f9ae8c3a81c4c73cf23ece1866d5.tar.bz2
gentoo-3da8c4d94cf9f9ae8c3a81c4c73cf23ece1866d5.zip
dev-python/docker-py: Bump to 4.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/docker-py')
-rw-r--r--dev-python/docker-py/Manifest1
-rw-r--r--dev-python/docker-py/docker-py-4.4.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/docker-py/Manifest b/dev-python/docker-py/Manifest
index 694ea2505898..877b4c76fa86 100644
--- a/dev-python/docker-py/Manifest
+++ b/dev-python/docker-py/Manifest
@@ -1 +1,2 @@
DIST docker-py-4.3.1.tar.gz 236548 BLAKE2B 2934410e9360ac0a0ea4a038fe75728252804c3ffc2dfb614d217a1771d6c61b50c93b1848df5c34f3bf6b6ad2fb98fc5295165c6a482895b6e7c8ef29bc658a SHA512 f82d8681edc866e73dcc0557a2be7ccfcb68e6add3cfd034d62f9639646c5d396e8e2b29df2b42006ee92adc8b432ca6a80bf2a10b54af42f33fe5ea8ed4a912
+DIST docker-py-4.4.0.tar.gz 246544 BLAKE2B d19b923499bb32f85728f88e479db330f442ddc32da06cad6f56cfff3386a020e45a0ede1afff635ce3d0e2d5e9112b0a4022969f75647eb6e57c13ef1bd6cb0 SHA512 8882a6547570d64c4cf9db7e1bd5ad13dca9a5b439631f3436587aecc1ed3386b230f9b6f82c07d9614f7d29d918ec6a3733fa6af6d8784a698e1b8459d4dcbc
diff --git a/dev-python/docker-py/docker-py-4.4.0.ebuild b/dev-python/docker-py/docker-py-4.4.0.ebuild
new file mode 100644
index 000000000000..530692235251
--- /dev/null
+++ b/dev-python/docker-py/docker-py-4.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ 'dev-python/recommonmark' \
+ '>=dev-python/sphinx-1.4.6'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # localhost has a better chance of being in /etc/hosts
+ sed -e 's:socket[.]gethostname():"localhost":' \
+ -i tests/unit/api_test.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/unit/ || die "tests failed under ${EPYTHON}"
+}