summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-22 13:57:54 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-22 14:10:14 +0100
commitbc9ab1a2ab6419fa03e4217c9c768c2a716bc56a (patch)
tree984ecd7172a75e089f4694f9d99d912af5f91d14 /dev-python/docopt/docopt-0.6.2-r4.ebuild
parentdev-python/llfuse: keyword 1.4.1 for ~riscv (diff)
downloadgentoo-bc9ab1a2ab6419fa03e4217c9c768c2a716bc56a.tar.gz
gentoo-bc9ab1a2ab6419fa03e4217c9c768c2a716bc56a.tar.bz2
gentoo-bc9ab1a2ab6419fa03e4217c9c768c2a716bc56a.zip
dev-python/docopt: make tests compatible with >=pytest-6
While at it, remove bits which are now handled by the eclass. Invoking maintainer time-out. Closes: https://bugs.gentoo.org/737924 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/docopt/docopt-0.6.2-r4.ebuild')
-rw-r--r--dev-python/docopt/docopt-0.6.2-r4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/docopt/docopt-0.6.2-r4.ebuild b/dev-python/docopt/docopt-0.6.2-r4.ebuild
new file mode 100644
index 000000000000..43fc62d58dfe
--- /dev/null
+++ b/dev-python/docopt/docopt-0.6.2-r4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic argument parser, that will make you smile"
+HOMEPAGE="https://pypi.org/project/docopt/ https://github.com/docopt/docopt"
+SRC_URI="https://github.com/docopt/docopt/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.2-pytest_node_from_parent.patch
+)
+
+distutils_enable_tests pytest