summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-24 21:38:04 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-24 21:42:10 -0500
commit579c208134a5827c0ffcacda1a907196060b7a31 (patch)
tree7e0357b31fc618ecdb4a9aabf33044173f65c76d /dev-python/dogpile-cache
parentmail-client/thunderbird: version bump for security bug 576864 (diff)
downloadgentoo-579c208134a5827c0ffcacda1a907196060b7a31.tar.gz
gentoo-579c208134a5827c0ffcacda1a907196060b7a31.tar.bz2
gentoo-579c208134a5827c0ffcacda1a907196060b7a31.zip
dev-python/dogpile-cache: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/dogpile-cache')
-rw-r--r--dev-python/dogpile-cache/Manifest1
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-0.5.7.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/dogpile-cache/Manifest b/dev-python/dogpile-cache/Manifest
index 246402e2b3cd..e4af55e007dd 100644
--- a/dev-python/dogpile-cache/Manifest
+++ b/dev-python/dogpile-cache/Manifest
@@ -1,3 +1,4 @@
DIST dogpile.cache-0.5.1.tar.gz 169450 SHA256 1f3165222bc23418cb9d3f1a2c9d554a091f412e5bc871ea0c48a19b576d06c0 SHA512 e9b9b8b7caf269cfecc8d333bd04714d908860e1e54720ce3329fae7be14995f8de6f1225e0cf6a782d5ef53ddd3482acc36a3440eb772e03f3d5029faeecc5c WHIRLPOOL ba14fc61604c78af038b6520079bbca1a46a889abebf69305f5722142cd47a45da966d8db64ec24cc7148363a22b109d89e4200087cc235a0721aea94f5c6a2c
DIST dogpile.cache-0.5.2.tar.gz 173765 SHA256 acdcb69e7eb8421678172fe8709d6d92bf7249022a70e4d7c84316d4e2d1d1b5 SHA512 dcce0e06de4d053e16020ca32f210c79a7eab21b7d09a8041e655940f03e32c91919a26d75114fffa087bc8a33052d5b1b04aeaea92d663ba4237f2990de2f05 WHIRLPOOL 8cec6f397487dbd2d61e1ed0f9b96f08d0f560af2f13b92b819d5fb402616d59a8c1a50aab518c07413af40b9405214ff4b66448912e33839a7a8b9920541b76
DIST dogpile.cache-0.5.4.tar.gz 185676 SHA256 9eab7a5dc05ad1b6573144c4a2717226b5c38811f9ec29b514e774535a91ea24 SHA512 ae73b8c82745cbde7b46f532e127c044a01e7b85d2e91b5f0a16da51fb9d70d48e2de55278db68f892a9b604e4f32e19a4a73c11393e04b599c8892280f9b5fe WHIRLPOOL 97b6dd6374940f081d60a7eba43844f17f39dbfa6df14ef18e9e8241b844f467126f4ffca3dd284408855d46c7f2299bb24bc9f2715271e2303e440a3b912f95
+DIST dogpile.cache-0.5.7.tar.gz 288083 SHA256 dcf99b09ddf3d8216b1b4378100eb0235619612fb0e6300ba5d74f10962d0956 SHA512 52acc9027577bd254e3c9b88f1e178534ba3b74675b83ad5dcc37443f77e674018123499d0da42d856790c949d7cf0c2070d29110b083ee7e99c4040263cb06c WHIRLPOOL 74f94e870cb8b64ada6b032947804835d10ac952badf8cc10ad9ad066bd3d751aefd7352392da96a076502df46ade5dc5a50da50e45d89ce2221fec3d47a8b46
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.5.7.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.5.7.ebuild
new file mode 100644
index 000000000000..34cf9c6772c8
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-0.5.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="API built on a lock allowing access to expiring values while a single thread generates a new value."
+HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/dogpile-core-0.4.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-core-0.4.1[${PYTHON_USEDEP}] )"
+
+# This time half the doc files are missing; Do you want them? toss a coin
+
+python_test() {
+ # crikey. testsuite written for py3, 5 tests fail under py2.7
+ if [[ "${EPYTHON}" != "python2.7" ]]; then
+ nosetests || die "test failed under ${EPYTHON}"
+ else
+ einfo "testsuite restricted for python2.7"
+ fi
+}