summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2017-08-14 20:23:47 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-15 22:54:13 +0200
commitbd36ce4c400a0e6ceb0106e9481cf8b18a24398d (patch)
treef075afe43344687e610e81a567c82c55bfcdef54 /dev-python/dogpile-cache
parentdev-python/spyder: Fix metadata.xml (diff)
downloadgentoo-bd36ce4c400a0e6ceb0106e9481cf8b18a24398d.tar.gz
gentoo-bd36ce4c400a0e6ceb0106e9481cf8b18a24398d.tar.bz2
gentoo-bd36ce4c400a0e6ceb0106e9481cf8b18a24398d.zip
dev-python/dogpile-cache: version bump to 0.7.4.
This commit: * bumps EAPI to version 6. * enables python version 3.6. Tests now work with Python 2.7. Package-Manager: Portage-2.3.7, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5420
Diffstat (limited to 'dev-python/dogpile-cache')
-rw-r--r--dev-python/dogpile-cache/Manifest1
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-0.6.4.ebuild30
-rw-r--r--dev-python/dogpile-cache/metadata.xml8
3 files changed, 35 insertions, 4 deletions
diff --git a/dev-python/dogpile-cache/Manifest b/dev-python/dogpile-cache/Manifest
index 1a702001453f..b14496325c18 100644
--- a/dev-python/dogpile-cache/Manifest
+++ b/dev-python/dogpile-cache/Manifest
@@ -1,2 +1,3 @@
DIST dogpile.cache-0.6.1.tar.gz 324046 SHA256 69b52dc56bb52d974e9e9fb2764e1311abcd1fd625de07b4e5c05550ac9b40c0 SHA512 c4743a88688d8f596469f2b3adf0cd862dd32891ae8c50d0c0421a984dfec872cbbecf936f704cf4351ae26b3ab4a26ae3b416f7c7f2ce3c41f8da2c9223178b WHIRLPOOL 3e9d4f8475efd34786f8722a9073cbb434bef8a8f5ada22e0309b143fda2a3909af91d69fb2092f6443a1e4ede9650529afbae2514c1374739582eecf05e1ffc
DIST dogpile.cache-0.6.2.tar.gz 329762 SHA256 73793471af07af6dc5b3ee015abfaca4220caaa34c615537f5ab007ed150726d SHA512 5882e0a355db0bec9c1a0836034481d39008051ff42f48c85679ac70a42c6366d1bcbd01ecd3ca868d7ad725197e626e52b004d62269827e2605a4ecd491ce99 WHIRLPOOL c88f0c503b157c65aae4881b7339c7af7f5b5b045d812220e59736fc78737ae7004bbc0595b5cfed590e5b7d76331b156fa0f28805981bee49ff666a3172ee78
+DIST dogpile.cache-0.6.4.tar.gz 315533 SHA256 a73aa3049cd88d7ec57a1c2e8946abdf4f14188d429c1023943fcc55c4568da1 SHA512 0e86ed6aacbfbbbefdc3622ac956679c4986c77989daa3c3e845d4b8dbbf7945b4d0764789f03540b2ff59712e2ee86c8283cc3ee8d9e950f9ef1772db7ea137 WHIRLPOOL ede8bff7a2d742a75b6d7aa40d42d17366379009d5cc9ac6313fe0523f906646e381537f7079564db14126db5314aede7b7d7c91818c707aee107dcefa47ea73
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.6.4.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.6.4.ebuild
new file mode 100644
index 000000000000..f42dbc5de8e0
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-0.6.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value."
+HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}] )"
+
+# This time half the doc files are missing; Do you want them? toss a coin
+
+python_test() {
+ "${EPYTHON}" ./setup.py test || die "test failed under ${EPYTHON}"
+}
diff --git a/dev-python/dogpile-cache/metadata.xml b/dev-python/dogpile-cache/metadata.xml
index f5fa387f97b0..823622b3f9e7 100644
--- a/dev-python/dogpile-cache/metadata.xml
+++ b/dev-python/dogpile-cache/metadata.xml
@@ -10,10 +10,10 @@
<name>Openstack</name>
</maintainer>
<longdescription lang="en">
- A caching API built around the concept of a "dogpile lock", which allows
- continued access to an expiring data value while
- a single thread generates a new value.
- </longdescription>
+ A caching API built around the concept of a "dogpile lock", which allows
+ continued access to an expiring data value while
+ a single thread generates a new value.
+ </longdescription>
<upstream>
<remote-id type="pypi">dogpile.cache</remote-id>
<remote-id type="bitbucket">zzzeek/dogpile.cache</remote-id>