summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-02 16:07:15 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-02 16:34:17 +0100
commit1afff92e33921ce7d5a9547a8d96352d8f7cb973 (patch)
tree39fd7dca489106b0a52aa21a02c8fed65397a7e9 /dev-python/doit
parentdev-python/doit-py: Remove py2 (diff)
downloadgentoo-1afff92e33921ce7d5a9547a8d96352d8f7cb973.tar.gz
gentoo-1afff92e33921ce7d5a9547a8d96352d8f7cb973.tar.bz2
gentoo-1afff92e33921ce7d5a9547a8d96352d8f7cb973.zip
dev-python/doit: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/doit')
-rw-r--r--dev-python/doit/doit-0.29.0.ebuild3
-rw-r--r--dev-python/doit/doit-0.32.0.ebuild1
2 files changed, 1 insertions, 3 deletions
diff --git a/dev-python/doit/doit-0.29.0.ebuild b/dev-python/doit/doit-0.29.0.ebuild
index f8c1f29e2285..c4bf8bd37a49 100644
--- a/dev-python/doit/doit-0.29.0.ebuild
+++ b/dev-python/doit/doit-0.29.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit eutils distutils-r1
RESTRICT="test" # can't work as it imports nonexistant modules from coverage
@@ -20,7 +20,6 @@ RDEPEND="
dev-python/cloudpickle[${PYTHON_USEDEP}]
dev-python/pyinotify[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' python2_7 pypy)
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
DEPEND="test? ( ${RDEPEND}
diff --git a/dev-python/doit/doit-0.32.0.ebuild b/dev-python/doit/doit-0.32.0.ebuild
index ecf024be21fe..347f0c06dfe8 100644
--- a/dev-python/doit/doit-0.32.0.ebuild
+++ b/dev-python/doit/doit-0.32.0.ebuild
@@ -22,7 +22,6 @@ RDEPEND="
dev-python/cloudpickle[${PYTHON_USEDEP}]
dev-python/pyinotify[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' python2_7 pypy)
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
DEPEND="test? ( ${RDEPEND}