summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-02-29 23:03:02 +0100
committerSebastian Pipping <sping@gentoo.org>2020-02-29 23:03:25 +0100
commit1e409299a685bd90282e4345c54559509e256a8b (patch)
tree0f818b2240bec4d82cbbcfa0f3ef53bf4fb75155 /dev-python/doublex-expects
parentdev-python/doublex: 1.9.2 + EAPI 7 + py37 (diff)
downloadgentoo-1e409299a685bd90282e4345c54559509e256a8b.tar.gz
gentoo-1e409299a685bd90282e4345c54559509e256a8b.tar.bz2
gentoo-1e409299a685bd90282e4345c54559509e256a8b.zip
dev-python/{doublex-expects,expects,mamba}: EAPI 7 + py37
All in one commit because of this depenceny graph: - doublex-expects: RDEPEND expects, DEPEND mamba - expects: DEPEND mamba - mamba: DEPEND expects, doublex-expects Bug: https://bugs.gentoo.org/711092 Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'dev-python/doublex-expects')
-rw-r--r--dev-python/doublex-expects/doublex-expects-0.7.0_rc2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/doublex-expects/doublex-expects-0.7.0_rc2-r1.ebuild b/dev-python/doublex-expects/doublex-expects-0.7.0_rc2-r1.ebuild
new file mode 100644
index 000000000000..cd9fa0da3b3e
--- /dev/null
+++ b/dev-python/doublex-expects/doublex-expects-0.7.0_rc2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Expects matchers for Doublex test doubles assertions"
+HOMEPAGE="https://github.com/jaimegildesagredo/doublex-expects"
+SRC_URI="https://github.com/jaimegildesagredo/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-python/mamba[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ dev-python/doublex[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.8.0_rc1[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ mamba || die "Tests failed under ${EPYTHON}"
+}